help with "yum update" failing

chrisbuk

Well-Known Member
PartnerNOC
Dec 7, 2003
397
1
168
Liverpool, United Kingdom
cPanel Access Level
DataCenter Provider
Twitter
Hi

when running yum update after installing whm/cpanel i get:

---> Package lvm2.i386 0:2.02.40-6.el5 set to be updated
--> Processing Dependency: device-mapper >= 1.02.28-2 for package: lvm2
--> Processing Dependency: kpartx = 0.4.7-17.el5 for package: device-mapper-multipath
filelists.xml.gz 100% |=========================| 2.8 MB 00:01
filelists.xml.gz 100% |=========================| 1.0 MB 00:00
filelists.xml.gz 100% |=========================| 133 kB 00:00
filelists.xml.gz 100% |=========================| 150 B 00:00
--> Finished Dependency Resolution
Error: Missing Dependency: kpartx = 0.4.7-17.el5 is needed by package device-mapper-multipath
Error: Missing Dependency: device-mapper >= 1.02.28-2 is needed by package lvm2



i have tried running:

yum clean all

then yum update, same issue

also tried

yum clean dbcache then yum update, again same issue.

Centos 5.2 x86

can anyone help fix this?
 

chinmay

Well-Known Member
Jul 22, 2008
101
0
66
localhost
It seems that that yum is trying to update lvm2 rpm and not able to get the update the rpm's for the dependencies device-mapper..

Description:
LVM2 includes all of the support for handling read/write operations on
physical volumes (hard disks, RAID-Systems, magneto optical, etc.,
multiple devices (MD), see mdadd(8) or even loop devices, see
losetup(8)), creating volume groups (kind of virtual disks) from one
or more physical volumes and creating one or more logical volumes
(kind of logical partitions) in volume groups.

Try installing the rpm's with the dependencies with yum before updating...

Hope this helps ;)
 

chrisbuk

Well-Known Member
PartnerNOC
Dec 7, 2003
397
1
168
Liverpool, United Kingdom
cPanel Access Level
DataCenter Provider
Twitter
hi

the ones that wont update i have added to exclude list

on one server i get:

Missing Dependency: libpq.so.4 is needed by package dovecot-1.0.7-2.el5.i386

However dovecot is in the exclusions list, why would this be trying to update?
 

chinmay

Well-Known Member
Jul 22, 2008
101
0
66
localhost
hi

the ones that wont update i have added to exclude list

on one server i get:

Missing Dependency: libpq.so.4 is needed by package dovecot-1.0.7-2.el5.i386

However dovecot is in the exclusions list, why would this be trying to update?
Yes, you have added dovecot in exclusion's list, but seems that "libpq.so.4" is a dependency required by dovecot... Try adding libpq.so.4 in the exclusion list too :)
 

chrisbuk

Well-Known Member
PartnerNOC
Dec 7, 2003
397
1
168
Liverpool, United Kingdom
cPanel Access Level
DataCenter Provider
Twitter
Yes, you have added dovecot in exclusion's list, but seems that "libpq.so.4" is a dependency required by dovecot... Try adding libpq.so.4 in the exclusion list too :)
tried that, didnt fix it, it still comes up with the same error.