The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hide ip from Spamhaus Policy Block List

Discussion in 'E-mail Discussions' started by xavierkca, Mar 29, 2010.

  1. xavierkca

    xavierkca Active Member

    Joined:
    Feb 24, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Our webserver is hosted in a professional datacenter. For some reason Spamhaus is detecting the sender's home address and not the servers source address. Is there anyway using exim to block the sender's home "received" address and use the server's source address to stop our company emails from being rejected.


    Thank you!
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    That's not just that users IP, it's a whole block of IPs. Reason is [too many] users are not using comcasts outgoing mail server settings as explained on the comcast site.
    /http://customer.comcast.com/Pages/FAQViewer.aspx?seoid=Setting-up-Outlook-2003
     
  3. xavierkca

    xavierkca Active Member

    Joined:
    Feb 24, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    We aren't trying to do anything about the specific IP. We don't want to use Comcast's email services and we shouldn't be forced to. I we use secure ports and thus have our own equipment. To the outside world, we want the server to be originator, not their home connection.

    If possible maybe for a specific domain. If I need to know who the originator's IP is, I can look in the logs.
     
    #3 xavierkca, Mar 29, 2010
    Last edited: Mar 29, 2010
  4. xavierkca

    xavierkca Active Member

    Joined:
    Feb 24, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Does anyone have any suggestions or ideas?
     
  5. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    Isn't it up to the individual user to configure their SMTP settings on their home computers? If they are using comcast (their ISP I assume) and comcast is being blocked, they should use their own domain for SMTP.
     
  6. xavierkca

    xavierkca Active Member

    Joined:
    Feb 24, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    No they have the correct information set up in their SMTP. The issue is exim reports the source IP that created the email in the headers. This new policy detects that it originated from a Comcast customer and rejects the email, no matter what, unless they use Comcast's smtp servers, which is what we want to avoid.

    I found a workaround, for anyone else who has a similar issue follow these instructions.

    In WHM -> Exim Configuration -> Advanced Editor

    Add the following in the first box:

    Code:
    received_header_text = Received: ${if def:sender_rcvhost {from ${if def:authenticated_id {localhost}{$sender_rcvhost}}\n\t}{${if def:sender_ident {from ${quote_local_part:$sender_ident} }}}}by $primary_hostname ${if def:received_protocol {with $received_protcol}} ${if def:tls_cipher {($tls_cipher)\n\t}}(Exim $version_number)\n\t${if def:sender_address {(envelope-from <$sender_address>)\n\t}}id $message_exim_id${if def:received_for {\n\tfor $received_for}}

    If the message is from an authenticated user, it will display "localhost" instead of the senders home ip address, thus resolving the issue.
     
  7. Vinu007

    Vinu007 Member

    Joined:
    Aug 9, 2006
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    0
    Hello,

    Such issue's are mostly caused due to SMTP tweaks option enabled.
    Make sure >>> "WHM > Security Center > SMTP Tweak" option must be disabled.

    This should avoid the server IP being blocked at any Spam Cop Policy.
     
  8. Meredith@HGM

    Meredith@HGM Registered

    Joined:
    Apr 19, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hey xavierkca , I tried your code on my server, and all it managed to do was shut down my email for several hours. Looks like I got lucky and all the emails are delivering now that I've reversed the tweak, but I was really hoping your solution would work!

    That said, I'm having this exact problem with one of my clients, and I have no idea what to do.
     
  9. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    938
    Likes Received:
    0
    Trophy Points:
    16
    I am also having the exact issue, many of our clients are spread in our different servers & their ISP's IP address(es) is listed in pbl,xbl so they are not able send/receive emails using any email client, e.g outlook express, Microsoft Outlook 2003, 2007, ThunderBird,. However there is an option to disable RBLs check in Exim Configuration and also tried to whitelisted their ISP's but its all not working.

    Please give us any alternate solutions
     
  10. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
  11. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    938
    Likes Received:
    0
    Trophy Points:
    16
    I have confused :( what exactly to do
     
  12. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:

    My IP (block) is listed at spamhaus. I think you might find more than a few ISPs IPs are. If you check spamhaus for example, you will find this message:

    I think if one of your customers is having issues they might want to use this tip.
     
Loading...

Share This Page