The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

High CPU usage, please help :(

Discussion in 'Workarounds and Optimization' started by DesiRockerz, Dec 24, 2013.

  1. DesiRockerz

    DesiRockerz Registered

    Joined:
    Dec 24, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello, I experienced a very high CPU usage and I have no idea what the issue is, I cant get support from my hosting company either because its unmanaged vps.

    I have attached a screenshot of my problem below:
     

    Attached Files:

  2. DesiRockerz

    DesiRockerz Registered

    Joined:
    Dec 24, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    The chkservd sub-process with pid 3833 ran for 301 seconds. This sub-process was terminated when it exceeded the time allowed between checks, which is 300 seconds. To determine why, you can check /var/log/chkservd.log and /usr/local/cpanel/logs/tailwatchd_log.

    You likely received this notification as a symptom of a larger problem. If your server is experiencing a high load, we recommend investigating the cause. If you continue to receive this notification, it is likely that your system is unable to handle demand or a misconfiguration is delaying restarts.

    If you are sure that no misconfigurations exist, you should consider gradually increasing the following options in WHM's "Tweak Settings" feature: "The number of times ChkServd will allow a previous check to complete before terminating the check" and/or "The number of seconds between ChkServd service checks".

    Server: vmi16248
    Primary IP: *********
    Service: chkservd
    Notification Type: hang
    Memory Information:
    Used: 9441MB
    Available: 6457MB
    Installed: 15949MB
    Load Information: 467.75 366.68 193.72
    Uptime: 0 days, 12 hours, 57 seconds
    IOStat Information:
    avg-cpu: %user %nice %system %iowait %steal %idle
    20.12 0.02 5.28 0.51 6.08 67.99
    Device: tps Blk_read/s Blk_wrtn/s Blk_read Blk_wrtn
    vda 32.46 180.60 1355.62 8440852 63357368
    vdb 0.01 0.07 0.52 3234 24432
    ChkServd Version: 15.2

    can you please explain what this error is?
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    The key information included with that email notification is your server load:

    Try using the link from my previous post in this thread to troubleshoot the load issue.

    Thank you.
     
  4. wswd

    wswd Well-Known Member

    Joined:
    Aug 9, 2005
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Just out of curiosity....what in the world are you doing on that VPS?!?!?!

    I've been in the industry for almost 20 years, and I don't think I have ever seen loads anywhere close to 500.
     
  5. thinkbot

    thinkbot Well-Known Member

    Joined:
    Oct 30, 2012
    Messages:
    326
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    probably I/O problems
     
Loading...

Share This Page