The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

High CPU usage with spam assassin

Discussion in 'General Discussion' started by bsasninja, Jul 11, 2007.

  1. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    16
    I upgraded to cpanel 11 lately and I activated spamassassin global on at the whm exim configuration editor.
    I see top process consuming 80% and 90% of cpu and it stay there more than 5 minutes and the load goes high.

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    7589 username 25 0 59456 54m 2104 R 94% 1.6 5:33.51 spamd

    Also at /var/log/exim_paniclog I have a lot of this lines:

    2007-07-11 16:48:35 1I8i8w-0003vi-U6 spam acl condition: error reading from spamd socket: Connection timed out
    2007-07-11 16:48:37 1I8i8z-0003vv-E5 spam acl condition: error reading from spamd socket: Connection timed out
    2007-07-11 16:48:42 1I8i93-0003wg-Mn spam acl condition: error reading from spamd socket: Connection timed out
    2007-07-11 16:48:49 1I8i9A-0003xP-VB spam acl condition: error reading from spamd socket: Connection timed out
    2007-07-11 16:48:51 1I8i9C-0003xS-FS spam acl condition: error reading from spamd socket: Connection timed out
    2007-07-11 16:48:54 1I8i9F-0003y3-Sn spam acl condition: error reading from spamd socket: Connection timed out
    2007-07-11 16:48:54 1I8i9C-0003xZ-OZ spam acl condition: error reading from spamd socket: Connection timed out
    2007-07-11 16:49:03 1I8i9O-0003ya-6K spam acl condition: error reading from spamd socket: Connection timed out
    2007-07-11 16:49:03 1I8i9N-0003yk-SQ spam acl condition: timed out writing spamd socket
    2007-07-11 16:49:03 1I8i9P-0003yr-CZ spam acl condition: error reading from spamd socket: Connection timed out
    2007-07-11 16:49:04 1I8i9P-0003yf-VH spam acl condition: error reading from spamd socket: Connection timed out
    2007-07-11 16:49:06 1I8i9R-0003yo-Ay spam acl condition: error reading from spamd socket: Connection timed out
    2007-07-11 16:49:11 1I8i9W-0003za-Nh spam acl condition: error reading from spamd socket: Connection timed out
    2007-07-11 16:49:13 1I8i9Z-0003zs-3J spam acl condition: error reading from spamd socket: Connection timed out

    What could be the problem? I have to stop and start exim to make the process dissapear.
     
    #1 bsasninja, Jul 11, 2007
    Last edited: Jul 11, 2007
  2. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    16
    I see that this problem happens with a particular account
    the spamd process is at the top of the running processes eating 90% of cpu

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    8563 username 25 0 45732 40m 2096 R 90 1.2 43:39.20 spamd

    Spamassasin is enabled globally, I tried to disable from cpanel for that account but It keeps enabled.

    What could i do???
     
  3. eeadmin

    eeadmin Well-Known Member

    Joined:
    Oct 21, 2004
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Dallas, TX
    Same Here

    Same here did you ever find a resolution?
     
  4. tweakservers

    tweakservers Well-Known Member

    Joined:
    Mar 30, 2006
    Messages:
    379
    Likes Received:
    0
    Trophy Points:
    16
    if SA is enabled globally, you will not be able to turn this off per account.
     
  5. markhard

    markhard Well-Known Member

    Joined:
    Apr 22, 2004
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    16
    I'm encounter the same problem, and only to 1 specific account. the rest of accounts inside the same server did have the problem.

    any fix on this spamd resource hog?
     
  6. MichaelShanks

    MichaelShanks Well-Known Member
    PartnerNOC

    Joined:
    Aug 20, 2001
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    remove the users .spamassassin directory in /home/username and restart exim

    will remove their settings, but better than 100% cpu hog,
     
Loading...

Share This Page