supersurver

Member
Sep 6, 2008
5
0
51
Hi,

Currently we have a high inodes problem on our server.
I've located the folder with the high inodes usage, and it looks like its Logaholic.
The folder is: /var/cpanel/userhomes/cpanellogaholic

Is there something we can do to prevent this issue from happening again without losing our customers stats?

Best Regards
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,234
363
cPanel Access Level
DataCenter Provider
Twitter
Hello :)

You may want to reduce the storage size value in Logaholic to reduce the number of inodes it uses. The following instructions for this were provided by one of our analysts to a customer facing a similar issue:

By default in Logaholic (before any changes cPanel makes) these settings can be updated by only by users that are Administrators and user's that have the ability to add a new profile. By default, no user's are Admins (or have the ability to add profiles), but you can change that in the database with a query like:

Code:
mysql> update _logaholic_users set isAdmin = 1 where username = "USER";
Once you do that, the USER specified will have the editable fields.

If you don't wish to make a user an admin, you can update the data for everyone directly in the MySQL database using:

Code:
mysql> select * from _logaholic_GlobalSettings where Name like "%datamanager%";;
+------------------------+---------+----------------------------------------+
| Name                   | Profile | Value                                  |
+------------------------+---------+----------------------------------------+
| datamanagerStorageSize |         | 1000                                   |
| datamanagersettings    |         | 1                                      |
| datamanagerDirectory   |         | /var/cpanel/userhomes/cpanellogaholic/ |
+------------------------+---------+----------------------------------------+
3 rows in set (0.07 sec)
Thank you.