The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

holy hell whats wrong with apache

Discussion in 'EasyApache' started by fujiwara takumi, Jan 12, 2004.

  1. fujiwara takumi

    fujiwara takumi Active Member

    Joined:
    Feb 11, 2003
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    i ran an upgrade on apache tonight, and this is how it ends:
    httpd status


    Nov 18 01:09:08 cobalt httpd: /etc/rc5.d/S99httpd: line 192: 983 Terminated $HTTPD -DSSL
    Nov 18 01:09:08 cobalt httpd: /etc/rc5.d/S99httpd start: httpd could not be started
    Nov 18 01:09:08 cobalt rc: Starting httpd: failed
    Nov 18 01:50:11 cobalt httpd: [Tue Nov 18 01:50:11 2003] [warn] NameVirtualHost 24.123.85.114:80 has no VirtualHosts
    Nov 18 01:50:11 cobalt httpd:
    Nov 18 01:50:11 cobalt httpd: [Tue Nov 18 01:50:11 2003] [warn] NameVirtualHost 24.123.85.114:80 has no VirtualHosts
    Nov 18 01:50:11 cobalt httpd: [Tue Nov 18 01:50:11 2003] [warn] NameVirtualHost 192.168.0.207:80 has no VirtualHosts
    Nov 18 01:50:12 cobalt httpd: /etc/rc5.d/S99httpd start: httpd started
    Nov 18 01:50:12 cobalt rc: Starting httpd: succeeded
    Can't connect at /scripts/restartsrv line 242, line 57153.
    Build Complete


    and i got no websites running now. any ideas? running on stable, release, and edge, same thing on all three. attempted via the WHM and via the SSH shell, same thing.
     
    #1 fujiwara takumi, Jan 12, 2004
    Last edited: Jan 12, 2004
  2. fujiwara takumi

    fujiwara takumi Active Member

    Joined:
    Feb 11, 2003
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    tried to run opt 6 from SSH client and get this:

    rm -f core *.o *~ lxdialog
    gcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -DLOCALE -I/usr/include/ncurses -DCURSES_LOC="<ncurses.h>" -c -o lxdialog.o lxdialog.c
    gcc: installation problem, cannot exec `cc1': No such file or directory
    make: *** [lxdialog.o] Error 1


    whats goin on?! :(
     
  3. fujiwara takumi

    fujiwara takumi Active Member

    Joined:
    Feb 11, 2003
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
  4. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
  5. Jeewhizz

    Jeewhizz Well-Known Member

    Joined:
    Mar 12, 2003
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    London, England
    type

    httpd configtest

    what do you get?
     
  6. fujiwara takumi

    fujiwara takumi Active Member

    Joined:
    Feb 11, 2003
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Syntax error on line 222 of /usr/local/apache/conf/httpd.conf:
    Cannot load /usr/local/apache/libexec/libphp4.so into server: libmcrypt.so.4: cannot open shared object file: No such file or directory
     
  7. fujiwara takumi

    fujiwara takumi Active Member

    Joined:
    Feb 11, 2003
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    does this mean anything useful?

    root@cobalt [~]# ldd /usr/local/apache/libexec/libphp4.so
    libmcrypt.so.4 => not found
    libltdl.so.3 => /usr/lib/libltdl.so.3 (0x40158000)
    libz.so.1 => /usr/lib/libz.so.1 (0x4015f000)
    libcrypt.so.1 => /lib/libcrypt.so.1 (0x4016d000)
    libresolv.so.2 => /lib/libresolv.so.2 (0x4019a000)
    libm.so.6 => /lib/libm.so.6 (0x401ab000)
    libdl.so.2 => /lib/libdl.so.2 (0x401cc000)
    libnsl.so.1 => /lib/libnsl.so.1 (0x401d0000)
    libc.so.6 => /lib/libc.so.6 (0x401e4000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
     
  8. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Probably won't help, but it's worth a try. Why don't you run upgrade apache through WHM?
     
  9. fujiwara takumi

    fujiwara takumi Active Member

    Joined:
    Feb 11, 2003
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    tried that a couple times.
     
  10. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Well, for now go into httpd.conf and comment out the following line:
    /usr/local/apache/libexec/libphp4.so
    Make it say:
    # /usr/local/apache/libexec/libphp4.so
    Then restart apache. At least your html pages will work. Then you can start working on fixing php.
     
  11. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Atleast casey's solution wud make your current system work. You wud need to rebuild apache again. I wud advise you to do it through shell. Choose properly the php modules required and rebuild it. Post the results here.

    If you still aren't able to fix it, PM me with your server details, i will help in fixing it.
     
Loading...

Share This Page