The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/home newusers permission

Discussion in 'General Discussion' started by arian40, Nov 18, 2007.

  1. arian40

    arian40 Registered

    Joined:
    Nov 6, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hi, I wanted a ask some thing about users and users who are added from cpanel permissions,

    for example how can i make the users not see others home directory or even the list of users in /home through SSH access, as all the users i add can do any thing to other users and go any directory,

    I also wanted to allow my users to be able to run ./configure so if they want to install ircds psybncor suchas only root access could. how could i give that sort of permission, so it can do it automatically to all new users when i add from cpanel.

    im using freebsd. thank you


    any help would be appriciated.
     
  2. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36
    Sounds like you are giving everyone full root access. Be sure to use jailshell instead. Look in tweak settings as well as reseller center "Use jailshell as the default shell for all new accounts and modified accounts"

    You will most likely need to set each account to use jailshell instead.
     
  3. arian40

    arian40 Registered

    Joined:
    Nov 6, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    its not root to all, but the user permission is abit high on the normal users. and jailshell ,, gives them how much access? whats their priority level..what can they do/not do
     
  4. Amit Deshmukh

    Amit Deshmukh Well-Known Member

    Joined:
    Jul 1, 2007
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Root

    You need to check the following file :-

    root@host [/etc]# pico passwd

    root:x:0:0:root:/root:/bin/bash
    advance:x:32009:32010::/home/advance:/usr/local/cpanel/bin/noshell (Advance is a User)


    Also you make edit the file :-

    root@host [/etc]# pico hosts.deny

    SSH : ALL

    root@host [/etc]# pico hosts.allow

    ALL : Your IP : all

    Let us know if you need further assistance.

    Thank you,
    Amit
     
Loading...

Share This Page