The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Home page Apache Issue?

Discussion in 'EasyApache' started by pratapsingh, Mar 26, 2009.

  1. pratapsingh

    pratapsingh Active Member

    Joined:
    Mar 20, 2009
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Hi

    I have installed apache , and i have configured it well there is no error in logs file.
    But I cant see my home page
    my document root Directory is /home/usr/public_html/index.html
    But It prompts only apache default page.
    I dont know whats happening there .
    Guide me .

    And for my other domain I am only abale to see the indexes, in this case apache default page is not viewable i don't understand this dual behaviour of apache.
    What is wrong in my configuration



    to view my conf file view this link coz i could not paste here

    http://www.linuxforums.org/forum/servers/143633-default-page-issue-apache.html#post681061
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,470
    Likes Received:
    199
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:

    That's what that is.

    Once you have the server setup, and at least one package setup, you need to create an account. Give it that package and you're off to the races.

    "Your" doc root would then be:

    /home/youraccountname/public_html/index.html

    You really shouldn't use root for an account which I think is what you've got going on here. (guessing)
     
  3. arren

    arren Member
    PartnerNOC

    Joined:
    Jul 24, 2008
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Please move your webfiles to /home/username/public_html . There is the only directory your apache will preview your site by default.
     
  4. Warrenw

    Warrenw Active Member
    PartnerNOC

    Joined:
    Nov 1, 2008
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    If you are viewing the index of the directory when you view the page through http create a .htaccess file in the document root or add this line to the current .htaccess:

    Options -Indexes

    Another solution is to add a index. file to be displayed.
     
Loading...

Share This Page