The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Horde 3 Problem in last EDGE

Discussion in 'General Discussion' started by Suter Rainer, Jan 27, 2005.

  1. Suter Rainer

    Suter Rainer Well-Known Member

    Joined:
    Jul 24, 2004
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    We have the newest EDGE version installed now come the following error with login the Mailadresse and the PW. Does someone have an idea?

    Warning: Division by zero in /usr/local/cpanel/base/horde/services/portal/index.php on line 59
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Try

    /usr/local/cpanel/bin/updatehorde
     
  3. Suter Rainer

    Suter Rainer Well-Known Member

    Joined:
    Jul 24, 2004
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6

    [~]# /usr/local/cpanel/bin/updatehorde
    Content-type: text/html
    X-Powered-By: PHP/4.3.10

    <br />
    <b>Warning</b>: main(Horde/CLI.php): failed to open stream: No such file or directory in <b>/usr/local/cpanel/base/horde/nag/scripts/upgrades/2004-09-13_add_uid_field.php</b> on line <b>18</b><br />
    <br />
    <b>Fatal error</b>: main(): Failed opening required 'Horde/CLI.php' (include_path='/usr/local/cpanel/3rdparty/lib/php/:.') in <b>/usr/local/cpanel/base/horde/nag/scripts/upgrades/2004-09-13_add_uid_field.php</b> on line <b>18</b><br />
    X-Powered-By: PHP/4.3.10
    Set-Cookie: Horde=a46c9160802c69284c3d61cd31d1d591; path=/horde
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Content-Type: text/html; charset=ISO-8859-1

    Converting categories for xxx@xxxxxx...

    ** Categories successfully converted ***
    ERROR 1060 at line 9: Duplicate column name 'object_uid'
    ERROR 1060 at line 10: Duplicate column name 'object_freebusyurl'
    ERROR 1060 at line 11: Duplicate column name 'object_smimepublickey'
    ERROR 1060 at line 12: Duplicate column name 'object_pgppublickey'
    X-Powered-By: PHP/4.3.10
    Set-Cookie: Horde=fe488bda88e6341b97977278d4c0b253; path=/horde
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Content-Type: text/html; charset=ISO-8859-1

    Creating default histories for localsql ...

    ** Default histories successfully created ***
    Package 'Log' already installed, skipping
    Package 'Mail_Mime' already installed, skipping
    Package 'File' already installed, skipping
    Package 'Date' already installed, skipping
    Package 'Net_Socket' already installed, skipping
    Package 'Net_URL' already installed, skipping
    Package 'Auth_SASL' already installed, skipping
    Package 'HTTP_Request' already installed, skipping
    root@delta [~]#
     
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Did it resolve the problem?
     
  5. damainman

    damainman Well-Known Member

    Joined:
    Nov 13, 2003
    Messages:
    515
    Likes Received:
    0
    Trophy Points:
    16
    nick which version of horde does the upgrade include.. horde 3.0 or 3.02 ?
     
  6. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    Nick, horde upgrade over the past few days has screwed me up so back I just took it from 1200 customers. No body left ..but I can verify similiar problems across multiple servers. Just wish now I could get eximstats to die and not come back to reduce loads.
     
  7. Suter Rainer

    Suter Rainer Well-Known Member

    Joined:
    Jul 24, 2004
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
  8. fusioncroc

    fusioncroc Well-Known Member

    Joined:
    Sep 28, 2004
    Messages:
    261
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    U.K.
    when i do the updatehorde thing i get the following

    Content-type: text/html
    X-Powered-By: PHP/4.3.10

    <br />
    <b>Warning</b>: main(Horde/CLI.php): failed to open stream: No such file or directory in <b>/usr/local/cpanel/base/horde/nag/scripts/upgrades/2004-09-13_add_uid_field.php</b> on line <b>18</b><br />
    <br />
    <b>Fatal error</b>: main(): Failed opening required 'Horde/CLI.php' (include_path='/usr/local/cpanel/3rdparty/lib/php/:.') in <b>/usr/local/cpanel/base/horde/nag/scripts/upgrades/2004-09-13_add_uid_field.php</b> on line <b>18</b><br />
    X-Powered-By: PHP/4.3.10
    Set-Cookie: Horde=8e2bf2f7d50d784e7936cdea7493fc59; path=/horde
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Content-Type: text/html; charset=ISO-8859-1


    ** Categories successfully converted ***
    ERROR 1060 at line 9: Duplicate column name 'object_uid'
    ERROR 1060 at line 10: Duplicate column name 'object_freebusyurl'
    ERROR 1060 at line 11: Duplicate column name 'object_smimepublickey'
    ERROR 1060 at line 12: Duplicate column name 'object_pgppublickey'
    X-Powered-By: PHP/4.3.10
    Set-Cookie: Horde=6cfe483217e1f10296d91e09039fdace; path=/horde
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Content-Type: text/html; charset=ISO-8859-1

    Creating default histories for localsql ...

    ** Default histories successfully created ***
    Package 'Log' already installed, skipping
    Package 'Mail_Mime' already installed, skipping
    Package 'File' already installed, skipping
    Package 'Date' already installed, skipping
    Package 'Net_Socket' already installed, skipping
    Package 'Net_URL' already installed, skipping
    Package 'Auth_SASL' already installed, skipping
    Package 'HTTP_Request' already installed, skipping
     
  9. networxhosting

    networxhosting Well-Known Member
    PartnerNOC

    Joined:
    Apr 22, 2003
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hamilton, Ontario, CANADA
    Also having the same issue here in latest EDGE (49) as well as having an issue where the side panel (left side) takes a while to load (delayed), and then i get a login error if i click on "Mail". If i click login after that, it works, but i then get random errors that i cant seem to replicate each time

    Any bugzilla links about this? if so, please post, as i would like to add to a few if i can to help resolve this
     
  10. poppyq

    poppyq Well-Known Member

    Joined:
    Jul 15, 2003
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Austin, TX
    I've got the login errors also. You login from domain.com/webmail, choose horde, logs in, then you click mail and it says not logged in.

    Another problem I'm seeing is on some email messages you get the following error:
    Fatal error: Cannot redeclare class text in /usr/local/cpanel/base/horde/lib/Text.php on line 26

    Any ideas?
     
  11. poppyq

    poppyq Well-Known Member

    Joined:
    Jul 15, 2003
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Austin, TX
    Actually it was a personal mistake. At some point in the past I had done "chattr +i" to the mime_drivers.php file for a setting I didn't want cpanel updates to overwrite, well Horde 3.0 really needed to update that file ;) It's resolved now, thanks for the help though.
     
Loading...

Share This Page