The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Horde and squirmail problem in 9.9.8

Discussion in 'E-mail Discussions' started by cyexx, Dec 16, 2004.

  1. cyexx

    cyexx Well-Known Member

    Joined:
    Sep 3, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    I was running Cpanel Current, and the webmail stopped working after an upgrade so i have tried stepping down to Release and Stable, and the only one that allows Horde and squirlmail to run is stepping down to Stable.

    I prefer not running Stable since security holes, is there any ideas on fixing this for release or current, since i have looked threw all the other posts and none of them fix this

    i think it might be an imap linker since neomail still works without a problem
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    What's the error message you're getting when trying to run Horde or Squirrelmail?
     
  3. cyexx

    cyexx Well-Known Member

    Joined:
    Sep 3, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
  4. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
  5. cyexx

    cyexx Well-Known Member

    Joined:
    Sep 3, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    it migh have some but these are the strings from cpanel directly from the webmail interface

    it seems to be a glich in the code changing from stable (working) to release and current (not working)

    and this is for freeBSD

    this is the only problem with current that i have seen but i have more problems with stable this is why i switched to current for all my things
     
  6. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    534
    Likes Received:
    0
    Trophy Points:
    16
    As of now, 9.9.9-STABLE_15 is the latest version... the others are out of date, even Edge and Beta... according to the build dates/times on Layer2.

    There were several bugs fixed, in between the first 9.9.9 Stable and the current 9.9.9 stable... perhaps that's why the stable is the only one that works for you?

    Just update to Stable for now and stay there until the next Current or Release comes out.
     
  7. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16

    Check out this thread to see if any binarys are missing.

    http://forums.cpanel.net/showthread.php?t=31213
     
  8. cyexx

    cyexx Well-Known Member

    Joined:
    Sep 3, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    It turnes out that it was the fix in this file "/scripts/makecpphp"

    but it looks like you have to redo the fix in the file and re-run the script after each update

    Replace this:

    Code:
    $MYSQL='--with-mysql';
    if (-e "/usr/local/bin/mysql") {
            $MYSQL='--with-mysql=/usr/local';
    }
    if (-e "/usr/bin/mysql") {
            $MYSQL='--with-mysql=/usr';
    }
    With this:

    Code:
    $MYSQL='--with-mysql';
    if (-e "/usr/local/bin/mysql") {
            $MYSQL='--with-mysql=/usr/local';
    }
    if (-e "/usr/bin/mysql") {
            $MYSQL='--with-mysql=/usr/local';
    }

    ---

    Thanks for the help
     
Loading...

Share This Page