Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Horde comes up Not Found

Discussion in 'General Discussion' started by onaweb, Aug 8, 2008.

  1. onaweb

    onaweb Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    156
    Hello,
    Just started today. When a client goes to /webmail to login, then clicks on Horde. It goes to domain:2095/horde/index.php which comes up "Page can not be displayed". We can login to RoundCube.

    So far the only thing I tried is /usr/local/cpanel/bin/update-horde --force

    We are running WHM 11.23.2 cPanel 11.23.4-R26138
    CENTOS Enterprise 4.6 i686 on standard - WHM X v3.1.0

    Any help will be greatly appreciated.

    Thanks,
    Andy
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,479
    Likes Received:
    421
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You might try a forced cPanel update via WHM and see if that sorts it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. onaweb

    onaweb Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    156
    Follow-up:

    When I do horde/test.php, I get these results at the end:
    Warning: Unknown: SQLite: session write query failed: database is full in Unknown on line 0

    Warning: Unknown: Failed to write session data (sqlite). Please verify that the current setting of session.save_path is correct (/var/cpanel/userhomes/cpanelhorde/sessions/phpsess.sdb) in Unknown on line 0
     
  4. onaweb

    onaweb Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    156
    Fixed it. I found this on another forum topic.

    Kindly try following steps:
    1. Login to shell of the server using root login details and open the file ” /usr/local/cpanel/3rdparty/etc/horde/php.ini ” using vi or any other editor
    2. Search for [Session] and change the following
    From:-
    session.save_handler = sqlite
    session.save_path =/var/cpanel/userhomes/cpanedmin/sessions/phpsess.sdb
    To:-
    session.save_handler = files
    session.save_path = /tmp

    3. Save and exit
    4. Restart Apache server using below command
    service httpd restart
     
  5. madpato

    madpato Well-Known Member

    Joined:
    May 30, 2008
    Messages:
    50
    Likes Received:
    1
    Trophy Points:
    58
    hi, i have a similar problem with the same errors... but when i try to edit the file... i just see random chars... i cant edit the file, i've tried with nano and i see nothing...
     
  6. cokequai

    cokequai Member

    Joined:
    Feb 15, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Chile, Santiago.
    Horde session

    The problem is when cpanel updates de horde, that fix is lost.
     
  7. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,216
    Likes Received:
    10
    Trophy Points:
    313
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    As of RELEASE 26829, we no longer use Sqlite for internal PHP.

    However, for other customizations, you may wish to create a /scripts/postupcp file to execute after every upcp to restore any of your customizations. Chmod +i on the files will be insufficient to retain customizations.
     
  8. igorfelluga

    igorfelluga Active Member

    Joined:
    May 31, 2006
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    156
    I have solved with this:
    Service Configuration > PHP Configuration Editor > Session Handling > /tmp
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. igorfelluga

    igorfelluga Active Member

    Joined:
    May 31, 2006
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    156
    continuing have the problem, how resolve it?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,216
    Likes Received:
    10
    Trophy Points:
    313
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I recommend submitting a support request for this so our technical analysts can determine why this is happening: http://tickets.cPanel.net/submit
     
  11. alex.lucas

    alex.lucas Member

    Joined:
    May 21, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    151
    Change Horde php.ini manually

    This fix works on cPanel 11.24.4-R34387 - WHM 11.24.2 - X 3.9 version.

    Open /usr/local/cpanel/3rdparty/etc/horde/php.ini file and see if configuration is like this:

    session.save_handler = files
    session.save_path = /var/cpanel/userhomes/cpanelhorde/sessions

    If you are using version above, your file may be like this. If it's not, change file as above. WHM option Service Configuration > PHP Configuration Editor > Session Handling > won't solve the problem. It won't change php.ini file you need. You have to edit file /usr/local/cpanel/3rdparty/etc/horde/php.ini manually. This option on WHM does not change Horde php.ini.

    Then you need to run /scripts/autorepair phpapps_owner_fix. At this point you may be able to run Horde.

    ATTENTION: If you use solution below, you will be able to access Horde but your attachments will be corrupted:

    session.save_handler = files
    session.save_path = /tmp
     
    #11 alex.lucas, Feb 4, 2009
    Last edited: Mar 8, 2009
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice