The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Horde Dead

Discussion in 'E-mail Discussions' started by ezhostingpro, Aug 27, 2005.

  1. ezhostingpro

    ezhostingpro Member

    Joined:
    Jan 24, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I just updated us to cpanel 10.6.0 and now I get this error while trying to access horde webmail

    Warning: canautologin(/usr/local/cpanel/base/horde/imp/lib/Block/../../config/servers.php): failed to open stream: No such file or directory in /usr/local/cpanel/base/horde/imp/lib/IMP.php on line 182

    Fatal error: canautologin(): Failed opening required '/usr/local/cpanel/base/horde/imp/lib/Block/../../config/servers.php' (include_path='/usr/local/cpanel/base/horde/lib:/usr/local/cpanel/3rdparty/lib/php/:.') in /usr/local/cpanel/base/horde/imp/lib/IMP.php on line 182

    The error shows up in the left frame but the right frame seems to work fne.

    I have tried updating again and also running resethorde though neither did any good. If any one knows what this error is or how to fix it please contact me,
     
  2. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    which version are u using ? stable, edge ?
     
  3. abubin

    abubin Well-Known Member

    Joined:
    Dec 7, 2004
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    did you try disabling horde and then reenabling it in whm? I did that and my horde works again.
     
  4. ncconquer

    ncconquer Well-Known Member

    Joined:
    Jun 20, 2004
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    i have problem with horde

    When i check my email by horde. In top left:

    ====
    Warning: fopen(/tmp/horde_32001.log): failed to open stream: Permission denied in /usr/local/cpanel/3rdparty/lib/php/Log/file.php on line 202

    Warning: Cannot modify header information - headers already sent by (output started at /usr/local/cpanel/3rdparty/lib/php/Log/file.php:202) in /usr/local/cpanel/base/horde/templates/common-header.inc on line 4

    Warning: Cannot modify header information - headers already sent by (output started at /usr/local/cpanel/3rdparty/lib/php/Log/file.php:202) in /usr/local/cpanel/base/horde/templates/common-header.inc on line 5
    ====
    Please tell me how can i fix it?
     
  5. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam
    The /tmp has the wrong rights, You must change the chmod to 777
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    /tmp should always be chmod 1777
     
  7. Bruce

    Bruce Well-Known Member

    Joined:
    Oct 4, 2001
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    We did the maildir update and still can't use Horde and /tmp is 1777


    Warning: fopen(/tmp/horde_32001.log): failed to open stream: Permission denied in /usr/local/cpanel/3rdparty/lib/php/Log/file.php on line 202

    Warning: Cannot modify header information - headers already sent by (output started at /usr/local/cpanel/3rdparty/lib/php/Log/file.php:202) in /usr/local/cpanel/base/horde/login.php on line 96

    Now fixed !
     
    #7 Bruce, Aug 29, 2005
    Last edited: Aug 29, 2005
  8. ezhostingpro

    ezhostingpro Member

    Joined:
    Jan 24, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Ok tmp is 1777, Disabled and re-enabled hored still dotn work same error.

    Vs ofcpanel is:

    WHM 10.6.0 cPanel 10.6.0-C66
    Fedora i686 - WHM X v3.1.0

    As stated earlier this happened after the cpanel scripts update that we ran due to the security warning cpanel has in the whm control panel.
     
  9. ezhostingpro

    ezhostingpro Member

    Joined:
    Jan 24, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I upgradded to 10.6.0_123 and it works again.
     
  10. ncconquer

    ncconquer Well-Known Member

    Joined:
    Jun 20, 2004
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    chmod 777 /tmp/horde_32001.log
    It's ok. Thanks
     
Loading...

Share This Page