Horde error when deleting emails on only 1 account

paulm

Well-Known Member
Oct 13, 2003
60
0
156
Today I noticed that when I tried to delete a message through horde I get the following error:

Notice: Undefined index: l in /usr/local/cpanel/base/horde/lib/Horde/IMAP/Tree.php on line 723

Notice: Undefined index: c in /usr/local/cpanel/base/horde/lib/Horde/IMAP/Tree.php on line 724

Notice: Undefined index: p in /usr/local/cpanel/base/horde/lib/Horde/IMAP/Tree.php on line 725

Notice: Undefined index: v in /usr/local/cpanel/base/horde/lib/Horde/IMAP/Tree.php on line 726

Warning: Cannot modify header information - headers already sent by (output started at /usr/local/cpanel/base/horde/lib/Horde/IMAP/Tree.php:723) in /usr/local/cpanel/base/horde/imp/templates/common-header.inc on line 4

Warning: Cannot modify header information - headers already sent by (output started at /usr/local/cpanel/base/horde/lib/Horde/IMAP/Tree.php:723) in /usr/local/cpanel/base/horde/imp/templates/common-header.inc on line 5
I checked all mail permissions, tried rebuilding horde and also did a upcp for the whole system hoping it may fix the issue. The issue is only with one account all other old and new accounts in cPanel login and delete in horde fine. I also check and this one account can delete messages fine in neomail and squirrelmail so it seems to just be a horde issue.

Thanks in advance for any ideas you may have.
 

carock

Well-Known Member
Sep 25, 2002
270
9
168
St. Charles, MO
Dude, 7 words or less... It took mne a few minutes to figure out wtf you're talking about.

Let me elaborate.

For that user, go to their Option tree on the left, and click the Mail link under it.

In the right pane, click "Deleting and Moving Messages"

There was some negative logic in my user's settings. The checkbox "When deleting messages, move them to your Trash folder instead of marking them as deleted?" was selected, but the Trash folder below it was set to None.

I had my user select a trash folder and his problem went away. I would also assume if you unchecked the move message option, it would also make the error go away.

Thanks for the hint :)

Chuck