The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Horde :: Fatal Error

Discussion in 'General Discussion' started by kinsky, Dec 22, 2007.

  1. kinsky

    kinsky Well-Known Member

    Joined:
    Jan 28, 2005
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    Help.. I have a problem like this on my new server

    A fatal error has occurred
    Failed to import Horde configuration: Warning: Registry::include(/usr/local/cpanel/base/horde/config/conf.php) [function.Registry-include]: failed to open stream: Permission denied in /usr/local/cpanel/base/horde/lib/Horde/Registry.php on line 874 Warning: Registry::include() [function.include]: Failed opening '/usr/local/cpanel/base/horde/config/conf.php' for inclusion (include_path='/usr/local/cpanel/base/horde/lib:/usr/local/cpanel/3rdparty/lib/php/:.') in /usr/local/cpanel/base/horde/lib/Horde/Registry.php on line 874

    I'm running WHM 11.11.0 cPanel 11.16.0-R18546
    FREEBSD 6.2-RELEASE i386 on standard - WHM X v3.1.0

    Regards
     
  2. Pat H

    Pat H Member

    Joined:
    Oct 28, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Canada
    cPanel Access Level:
    Root Administrator
    Yeah, I was just notified of this issue on one of our (FreeBSD) servers.

    Here's the fix:

    chown -R cpanel:cpanel /usr/local/cpanel/base/horde/


    For some reason after last nights update it was set to proftpd:cpanel, which is why Horde was failing...
     
  3. mccwho

    mccwho Member

    Joined:
    Nov 23, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I had the same problem so I tried it.
    Now I am getting an error from MySQL

    A fatal error has occurred
    Could not connect to database for SQL SessionHandler.
    Details have been logged for the administrator.

    any ideas??
     
  4. mccwho

    mccwho Member

    Joined:
    Nov 23, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I also tried
    upcp --force
    edited the conf.php for horde --- did not work
    checked my.cnf for the "skip -innodb" --- no good
    ran /scripts/fixmailperms --- did not work


    this is what worked;

    /scripts/fullhordereset

    fixed it.
     
  5. mike1s

    mike1s Member

    Joined:
    Mar 15, 2008
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Riverview, Florida, United States
    This fixed it for me also :):)
     
Loading...

Share This Page