SOLVED Horde filters not auto applying - filter preferences missing

ksechrist

Active Member
Jan 27, 2019
31
5
8
Texas
cPanel Access Level
Root Administrator
Horde groupmail 5.2.22
Users can create filters, but must go to Mail > Filters and click apply EVERY TIME for them to work.

When users go to Preferences > Filters, there are NO options - it just says "There are no preferences available for this application."

While digging around looking for configuration options, it LOOKS like horde is installed to work with php 7.2, but I'm not using 7.2 for any of the websites (it's not available as an option in cpanel - cpanel jumps from 7.1 to 7.3) - could this be the problem?

Or any other ideas? Filters that have to be manually applied each time aren't much help!
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
8,080
657
263
Houston
cPanel Access Level
DataCenter Provider
Users can create filters, but must go to Mail > Filters and click apply EVERY TIME for them to work.
Or any other ideas? Filters that have to be manually applied each time aren't much help!
We suggest you use the cPanel email filters UI for this functionality - from Horde nothing more than Whitelist/Blacklist should be filterable though this can all be managed from within the email filters in cPanel as well. Your email users can access this interface by going to the dropdown by their email account name in the top right hand corner of the email screen and selecting Email Filters.

While digging around looking for configuration options, it LOOKS like horde is installed to work with php 7.2, but I'm not using 7.2 for any of the websites (it's not available as an option in cpanel - cpanel jumps from 7.1 to 7.3) - could this be the problem?
cPanel's internal php is PHP 7.2 which is what horde is using, this is separate from the php that is installed for your sites to use.
 
  • Like
Reactions: ksechrist