Horde is using the wrong email address, rebuild fails

LoadFactor

Well-Known Member
Jul 12, 2013
53
7
133
cPanel Access Level
Root Administrator
I have an account that changed its main domain. All is well, except when the user is sending mail via horde. In this case the from address is [email protected]. The old domain is long gone, so the message fails to deliver.

I tried backing up the Sqlite database and running

Code:
/usr/local/cpanel/bin/update_horde_config --user=my_user_name --create-defaults
And, running as root, got this:

Code:
=my_user_name --create-defaultscal/cpanel/bin/update_horde_config --user
Running database checks for 1 account(s) …

Starting update of 1 user in parallel …

The Horde update for the user “my_user_name” failed because of an error:Can't locate Cpanel/Exception/CORE.pm:   /root/perl5/lib/perl5/Cpanel/Exception/CORE.pm: Permission denied at /usr/local/cpanel/Cpanel/Exception.pm line 64.
The user isn't using calendar or address books, so a rebuild won't have any impact, but is there's another way to update the user's email address?
 

cPanelLauren

Technical Support Community Manager
Staff member
Nov 14, 2017
13,237
1,232
313
Houston
It sounds like the user in question here just needs to change the From address in the horde mail client. When you load Horde, go to the Gear in the top Menu bar -> Select Preferences -> Global Preferences -> Personal Information and update the From Address.


For
Code:
/usr/local/cpanel/bin/update_horde_config --user=my_user_name --create-defaults
Are you putting in an email address specifically or are you putting in the domain username? Are you running this as the cPanel user or are you running it as root?
Running that as root should actually update the From address as well, at least it did for me when I ran it for my user while testing this.
 

LoadFactor

Well-Known Member
Jul 12, 2013
53
7
133
cPanel Access Level
Root Administrator
It sounds like the user in question here just needs to change the From address in the horde mail client. When you load Horde, go to the Gear in the top Menu bar -> Select Preferences -> Global Preferences -> Personal Information and update the From Address.


For
Code:
/usr/local/cpanel/bin/update_horde_config --user=my_user_name --create-defaults
Are you putting in an email address specifically or are you putting in the domain username? Are you running this as the cPanel user or are you running it as root?
Running that as root should actually update the From address as well, at least it did for me when I ran it for my user while testing this.
I tried that first and couldn't locate the from address setting.

I tried the update running as root, using the cPanel user name, following instructions found at Guide to Horde Data Behavior | cPanel & WHM Documentation

Unfortunately when I renamed horde.sqlite.bak back to horde.sqlite, something else went wrong. cPanel webmail works but when entering horde now I get a 503.
 

cPanelLauren

Technical Support Community Manager
Staff member
Nov 14, 2017
13,237
1,232
313
Houston
At this point to ensure everything gets back to working as intended I'd suggest you open a ticket so our analysts can get a full picture of what is occurring. When you do open a ticket please update this thread with the Ticket ID so I can follow up with the outcome here.