The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Horde language issue

Discussion in 'E-mail Discussions' started by marisat, May 8, 2006.

  1. marisat

    marisat Registered

    Joined:
    May 8, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    ok i am trying to change the language with horde. i go to the drop down menu, choose the language i want and then click connect and it goes back to english. i have done Upgrade to Latest Version and then ran Upgrade to Latest Version while logged in through ssh as root but still nothing....anyone got any ideas?
     
  2. mihosting

    mihosting Member

    Joined:
    Nov 30, 2003
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Madrid
    I have exactly the same problem. But I cannot find any reason. please help.
     
  3. Grzeslaw

    Grzeslaw Well-Known Member

    Joined:
    Jul 11, 2006
    Messages:
    76
    Likes Received:
    1
    Trophy Points:
    6
    Location:
    Poland
    Me too :( What Can It be ?
    Maby some permissions to some lang files ?
     
  4. websupport

    websupport Well-Known Member

    Joined:
    Jun 24, 2006
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    Check configuratiuon file

    There are a number of IMP features and functions which can be disabled in imp's configuration file, /horde/imp/config/defaults.php3.

    * Do not allow user to select language

    <?php
    $default->user_change_language = false
    ?>


    :)
     
  5. tarmo

    tarmo Member

    Joined:
    Feb 1, 2005
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    I didn't find that file?!? Did I miss something? Our users cannot change language also and Cpanel doesn't no also how to fix that(opened bug case many days ago, still OPEN).
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    This is a deficiency in Horde, all versions. The language selected at the login page does not necessarily translate the entire application interface with all browsers. IN 90%+ instances it translates the login page only, but once within the Horde Application, the interface is a combination of gibberish and English. The amount of gibberish depends upon the browser, with Safari having the least and FireFox having a lot.

    To have the Horde Application display properly in your language:

    1. Select the language from the dropdown list on the login page
    2. Login
    3. Select the Options page (Global Options)
    4. Select Locale
    5. The first dropdown allows you to specify your preferred language. Select the preferred language and Save the options.
    6. The entire web page should reload and now display in your preferred language. If it doesn't reload, click the refresh Button, or depress the F5 or CTRL+R keys to force a refresh.

    Once the above is performed, each time a person logs into Horde, your preferred language must be selected from the dropdown list on the Login page. If the wrong language is selected at the Login page then the Horde Application interface will again display a combination of gibberish and either English or your preferred language from the Global Options > Locale setting.

    A bug was filed with the Horde project regarding this. Once I find the corresponding bugzilla report in our system, I will post the link to the Horde bug within it, and post a link to both in this thread.
     
  7. grindlay

    grindlay Active Member

    Joined:
    Dec 8, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Edinburgh, Scotland
    cPanel Access Level:
    Root Administrator
    Horde Default Language

    Thanks.
    I know there is a way to change the default selection in the Horde language <select> box on the login page because I manage a cP/WHM server that has it defaulting to English (British).
    I have been through my config files at /usr/local/cpanel/base/horde and for the life of me I cannot find the setting that controls this.
    There is nothing in the Horde FAQ or mailing lists.
    Anyone?
     
  8. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    I'm working on a patch to simplify the horde login process with cPanel and that will hopefully resolve some of the language/login issues people have. It's in a bugzilla report, but I don't have the number at hand.

    The first part of the patch, in the report, removes the language selection page, since that causes the most confusion. The next part will make the language set in the users browser be the default, if one is not set in their horde profile. After that, and plenty of testing, I hope to get it integrated with a build.
     
Loading...

Share This Page