The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Horde Mail and Squirell mail failing after server restore

Discussion in 'E-mail Discussions' started by tech4771, Sep 8, 2005.

  1. tech4771

    tech4771 Registered

    Joined:
    Sep 7, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Help I have a problem with one of our servers.
    When I login under an account , click add/remove email accounts, then click read webmail and login with password, click on horde , click ok on english, It craps out with bunch of errors.

    I saw a post to repair the tables in here and it said it was successful so I ran
    connect horde
    repair table horde_sessionhandler
    It didnt work, and now I get different errors on the horde log.

    I was thinking perhaps the horde db is corrupted now, and maybe I can restore it. I just dont know where the files physically reside so I can restore it from backup.. any ideas anyone? Or what can I do to fix this problem anyone?

    I got the errors and the log files below... someone please help this poor admin who doesnt know crap about cpanel~ please~
    --------------------------------------
    on the top section - Horde Webmail

    Warning: fopen(/tmp/horde_32001.log): failed to open stream: Permission denied in /usr/local/cpanel/3rdparty/lib/php/Log/file.php on line 202

    Warning: Cannot modify header information - headers already sent by (output started at /usr/local/cpanel/3rdparty/lib/php/Log/file.php:202) in /usr/local/cpanel/base/horde/templates/common-header.inc on line 4

    Warning: Cannot modify header information - headers already sent by (output started at /usr/local/cpanel/3rdparty/lib/php/Log/file.php:202) in /usr/local/cpanel/base/horde/templates/common-header.inc on line 5
    --- bottom section --
    Notice: (null)(): No such host as localhost (errflg=2) in Unknown on line 0


    -----------------------------------------------------HORDE ERROR LOG ------
    Aug 31 16:21:03 HORDE [emergency] [horde] Could not connect to database for SQL SessionHandler. [on line 299 of "/usr/local/cp
    anel/base/horde/lib/Horde/SessionHandler/mysql.php"]
    Aug 31 16:21:03 HORDE [emergency] [horde] Could not connect to database for SQL SessionHandler. [on line 299 of "/usr/local/cp
    anel/base/horde/lib/Horde/SessionHandler/mysql.php"]
    Aug 31 16:21:03 HORDE [emergency] [horde] Could not connect to database for SQL SessionHandler. [on line 299 of "/usr/local/cp
    anel/base/horde/lib/Horde/SessionHandler/mysql.php"]
    Aug 31 16:25:38 HORDE [emergency] [horde] Could not connect to database for SQL SessionHandler. [on line 299 of "/usr/local/cp
    anel/base/horde/lib/Horde/SessionHandler/mysql.php"]
    Aug 31 16:25:38 HORDE [emergency] [horde] Could not connect to database for SQL SessionHandler. [on line 299 of "/usr/local/cp
    anel/base/horde/lib/Horde/SessionHandler/mysql.php"]
    Aug 31 16:25:38 HORDE [emergency] [horde] Could not connect to database for SQL SessionHandler. [on line 299 of "/usr/local/cp
    anel/base/horde/lib/Horde/SessionHandler/mysql.php"]

    ----ERROR LOG AFTER repair table horde_sessionhandler run --

    Sep 01 15:44:55 HORDE [error] [turba] DB Error: no such field: SELECT object_id, owner_id, object_type, object_members, object
    _uid, object_name, object_email, object_alias, object_homeaddress, object_workaddress, object_homephone, object_workphone, obj
    ect_cellphone, object_fax, object_title, object_company, object_notes, object_pgppublickey, object_smimepublickey, object_free
    busyurl FROM turba_objects WHERE (owner_id = 0) [nativecode=1054 ** Unknown column 'object_uid' in 'field list'] [on line 86 o
    f "/usr/local/cpanel/base/horde/turba/lib/Driver/sql.php"]
    Sep 07 13:48:54 HORDE [error] [turba] DB Error: no such field: SELECT object_id, owner_id, object_type, object_members, object
    _uid, object_name, object_email, object_alias, object_homeaddress, object_workaddress, object_homephone, object_workphone, obj
    ect_cellphone, object_fax, object_title, object_company, object_notes, object_pgppublickey, object_smimepublickey, object_free
    busyurl FROM turba_objects WHERE (owner_id = 0) [nativecode=1054 ** Unknown column 'object_uid' in 'field list'] [on line 86 o
    f "/usr/local/cpanel/base/horde/turba/lib/Driver/sql.php"]
     
  2. tmc74

    tmc74 Member

    Joined:
    Aug 17, 2003
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I have same error!

    Does anyone have any solution...?

    -TmC74
     
  3. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    try
    /usr/local/cpanel/bin/updatehorde
     
  4. gorilla

    gorilla Well-Known Member

    Joined:
    Feb 3, 2004
    Messages:
    699
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney / Australia
    am getting those errors after running /usr/local/cpanel/bin/updatehorde :eek:
    ------------------------
    Fatal error: Cannot instantiate non-existent class: pear_frontend_cli in /usr/local/cpanel/3rdparty/lib/php/PEAR/Command.php on line 144
    DBD::mysql::st execute failed: Table 'horde.horde_categories' doesn't exist at /usr/local/cpanel/bin/horde_update_usernames line 42.
    DBD::mysql::st fetchrow_hashref failed: fetch() without execute() at /usr/local/cpanel/bin/horde_update_usernames line 43.
    -----------------------


    on
    WHM 10.6.0 cPanel 10.8.0-R27
    CentOS 4.1 x86_64 - WHM X v3.1.0

    Any suggestions ?
     
  5. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    Same problem here and when we ran update we got this instead.

    ** Default histories successfully created ***
    Package 'Log' already installed, skipping
    Package 'Mail_Mime' already installed, skipping
    Package 'File' already installed, skipping
    Package 'Date' already installed, skipping
    Package 'Net_Socket' already installed, skipping
    Package 'Net_URL' already installed, skipping
    Package 'Auth_SASL' already installed, skipping
    Package 'HTTP_Request' already installed, skipping
    xml_rpc_client: Connection to RPC server pear.php.net:80 failed. Connection timed out
    DBD::mysql::st execute failed: Table 'horde.horde_categories' doesn't exist at /usr/local/cpanel/bin/horde_update_usernames line 42.
    DBD::mysql::st fetchrow_hashref failed: fetch() without execute() at /usr/local/cpanel/bin/horde_update_usernames line 43.


    When is this going to be fixed?
     
  6. gorilla

    gorilla Well-Known Member

    Joined:
    Feb 3, 2004
    Messages:
    699
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney / Australia
    For me the fix was by disabling ioncube in tweak settings and horde and phpmyadmin started working again
    This only effected my server running 64bit , all other ones didnt have this issue
     
    #6 gorilla, Oct 11, 2005
    Last edited: Oct 11, 2005
  7. xprt5

    xprt5 Well-Known Member

    Joined:
    Apr 6, 2003
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Houston
    I changed permissions on /tmp/horde_32001.log to chmod 777 and ran /usr/local/cpanel/bin/updatehorde

    Works great for me now.
     
  8. techniman

    techniman Member

    Joined:
    Mar 14, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I had the same error and this fix works, i did the following:

    changed permissions on /tmp/horde_32001.log to 777
    ran /usr/local/cpanel/bin/updatehorde
    repaired the table horde_sessionhandler
    changed permissions on /tml/horde_32001.log to 777
     
Loading...

Share This Page