Horde 'mail server closed the connection unexpectedly' Error

sukrub

Member
Oct 25, 2011
21
0
51
cPanel Access Level
Root Administrator
When I leave Horde unattended for a while. It produces an error message when it checks internally for new messages. It happens with roundCube as well.

Based on my observation it happens a lot more with Chrome then FF.

with Horde:
In Chrome when you try to refresh the browser, it asks you to re-login with 'your session cookie is invalid. Please log in again.'

In FF it keeps you logged in.

Chrome-Horde.jpg Chrome-RC.jpg FF.jpg
 
Last edited:

SysSachin

Well-Known Member
Aug 23, 2015
604
48
28
India
cPanel Access Level
Root Administrator
Twitter
Hello,

I think your IP is dynamically changing and due to that getting error while refresh the browser.

Please try to disable Cookie IP Validation and let me know the result.


You can disable it using WHM >> Tweak Settings >> Cookie IP Validation. Select the disabled radio button there and save.
 

sukrub

Member
Oct 25, 2011
21
0
51
cPanel Access Level
Root Administrator
5-10 minutes. However most clients are connected all day long. they use it as their main mail client.

Here is another clue (maybe?) The following email is received by root

subject: lfd on mailhost.tsgmx.com: Excessive resource usage: myAcctName (31731 (Parent PID:31503))

body:
Time: Tue Feb 23 13:16:29 2016 -0800
Account: myAcctName
Resource: Process Time
Exceeded: 9018 > 1800 (seconds)
Executable: /usr/local/cpanel/3rdparty/php/54/bin/php-cgi
Command Line: /usr/local/cpanel/3rdparty/php/54/bin/php-cgi -c /usr/local/cpanel/3rdparty/php/54/etc/horde /usr/local/cpanel/base/horde/services/ajax.php

PID: 31731 (Parent PID:31503)

Killed: No
 

sukrub

Member
Oct 25, 2011
21
0
51
cPanel Access Level
Root Administrator
We also get get 'Disconnected' notice on outlook running IMAP. Outlook does not reconnect until next manual send & receive.
We have solved this problem.

System security seemd to have alot of blocks for imap and pop We lowered the firewall and exim settings a little to see if that allows traffic. This fixed all issues related to mail server connections including webmail.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,225
463
I am happy to see the issue is now resolved. Thank you for updating us with the outcome.