The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

horde messed up

Discussion in 'General Discussion' started by Homie2, Nov 23, 2005.

  1. Homie2

    Homie2 Well-Known Member

    Joined:
    Dec 16, 2004
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    my horde email has been working fine for me on my account but one of my customers just told me all sudden horde seems to be down for him. He gets this error



    Notice: (null)(): Retrying LOGIN authentication after AUTHENTICATE LOGIN failed (errflg=1) in Unknown on line 0

    Notice: (null)(): Retrying LOGIN authentication after AUTHENTICATE LOGIN failed (errflg=1) in Unknown on line 0

    Notice: (null)(): Can not authenticate to IMAP server: AUTHENTICATE LOGIN failed (errflg=2) in Unknown on line 0


    How can i fix this for him because horde works fine for me and all my other customers.

    Thanks,
     
  2. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    First of all make sure that all permissions and ownerships are correct.If everything is correct then proceed with the below mentioned methods.I am mentioning some methods that I read from this forum and make notes of that so that for everytime I don't have to search the thread.

    METHOD-1
    ========
    This issue may be happening because the symlinks passwd.domain.com,shadow.domain.com and the uid.domain.com.gid.domain.com files in /etc/vmail are missing.

    Take a domain having issue and run the following command

    cd /etc/vmail
    ls -l|grep domain.com

    You should see something like this

    -rw-r--r-- 1 root root 5 Sep 30 22:52 gid.domain.com
    lrwxrwxrwx 1 root root 34 Sep 30 22:30 passwd.domain.com -> /home/user/etc/domain.com/passwd
    lrwxrwxrwx 1 root root 34 Sep 30 22:30 shadow.domain.com -> /home/user/etc/domain.com/shadow
    -rw-r--r-- 1 root root 5 Sep 30 22:52 uid.domain.com
    -rw-r--r-- 1 root root 0 Sep 30 22:30 vhost.domain.com

    If you are missing the above files, you can't login via imap

    We fixed the issue using the following method.

    touch /etc/passwd
    /scripts/updateuserdomains

    METHOD-2
    ========
    1. backup vmail dir if things go wrong

    mv /etc/vmail /etc/vmail-bak

    2. run /scripts/updateuserdomains

    If something went wrong, simply rm -rf /etc/vmail and mv /etc/vmail-bak /etc/vmail.

    Thanks to them who had posted this solution.
     
  3. Homie2

    Homie2 Well-Known Member

    Joined:
    Dec 16, 2004
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    how do i check to see if permissions are correct and if not what do i do?
     
  4. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    Run /scripts/mailperm, that will fix the permissions if it found incorrect on any of the mailbox.
     
  5. Homie2

    Homie2 Well-Known Member

    Joined:
    Dec 16, 2004
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    so i need to be in /home/hisdirectory/

    before i run that command correct?
     
  6. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    No, you can run it from anywhere.The script will correct the permissions for all mailboxes on the server.
     
  7. Homie2

    Homie2 Well-Known Member

    Joined:
    Dec 16, 2004
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    It didn't fix it ):
     
  8. Homie2

    Homie2 Well-Known Member

    Joined:
    Dec 16, 2004
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    root@ [/etc/vmail]# ls -l|grep domaint.net
    -rw-r--r-- 1 root root 5 Nov 22 15:44 gid.domain.net
    lrwxrwxrwx 1 root root 40 Oct 20 01:58 passwd.domain -> /home/jon
    seal/etc/domain.net/passwd
    lrwxrwxrwx 1 root root 40 Oct 20 01:58 shadow.domain.net -> /home/jon
    seal/etc/domain.net/shadow
    -rw-r--r-- 1 root root 5 Nov 22 15:44 uid.domain.net
    -rw-r--r-- 1 root root 0 Oct 20 01:58 vhost.domaint.net
     
    #8 Homie2, Nov 23, 2005
    Last edited: Nov 23, 2005
  9. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    Then finally you can go with /scripts/fullhordereset that will reset the Horde from scratch.
     
  10. Homie2

    Homie2 Well-Known Member

    Joined:
    Dec 16, 2004
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    well.. Will it delete my horde emails and mess anything up for my customers if i run that command/?
     
  11. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    No, it will not delete any mail.Anyway have you tried the Method-2 that I mentioned above.
     
  12. Homie2

    Homie2 Well-Known Member

    Joined:
    Dec 16, 2004
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    Yes, i did

    root@ [/etc/vmail]# mv /etc/vmail /etc/vmail-bak
    root@ [/etc/vmail]# /scripts/updateuserdomains
    [userdomains] domain conflict: /var/cpanel/users/msbhost contains a domain alrea
    dy owned by abhost at /scripts/updateuserdomains line 172, <F> line 3.
    [userdomains] user ultimafr: missing DNS= line in /var/cpanel/users/ultimafr at
    /scripts/updateuserdomains line 197.
    root@ [/etc/vmail]#
     
    #12 Homie2, Nov 23, 2005
    Last edited: Nov 23, 2005
  13. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    The file /var/cpanel/users/username is created for every user on the server and it contain the entries for the domains owned by that user.You can see that the /scripts/updateuserdomains is showing conflict becasue a domain entry exists in both /var/cpanel/users/msbhost and /var/cpanel/users/abhost.So for resolving this conflict , check that the domain actuallt owned by which user and then remove the domain entry from the other users file.

    The file /var/cpanel/users/ultimafr is missing the domain entry.Open the file and make an entry DNS=domain.com (replace the domain.com with the actual domain of the user ultimafr).

    After that run /scripts/updateuserdomains
     
  14. Homie2

    Homie2 Well-Known Member

    Joined:
    Dec 16, 2004
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    SOMETHING IS WRONG

    i did


    cd /etc/vmail


    it now asys no such file or directory
     
  15. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    Nothing is wrong.You forgot that you have renamed /etc/vmail to /etc/vmail-bak by issuing the command mv /etc/vmail /etc/vmail-bak.Its for to be on the safe side.When you will run /scripts/updateuserdomains it will create new /etc/vmail with the updated information
     
  16. Homie2

    Homie2 Well-Known Member

    Joined:
    Dec 16, 2004
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    NO!!! THERE IS NO etc/vmail-bak

    EITHER!
     
  17. Homie2

    Homie2 Well-Known Member

    Joined:
    Dec 16, 2004
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    LOL NVM> How do i get it back to vmail?
     
  18. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    Run /scripts/updateuserdomains
     
  19. Homie2

    Homie2 Well-Known Member

    Joined:
    Dec 16, 2004
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    1 issue left.

    i went and did that command Pico /var/cpanel/users/ultimafr

    and now what i do cause this pops up

    root@relapse [~]# /var/cpanel/users/ultimafr
    GNU nano 1.2.4 File: /var/cpanel/users/ultimafr

    BWLIMIT=73400320000
    FEATURELIST=default
    IP=45.45.34.34
    MAXADDON=1
    MAXPARK=1
    OWNER=ultimafr
    PLAN=roflcopterspecial1
    RS=x
    STARTDATE=1131042917
    DNS1=ns1.ultimafree.com
    DNS2=ns2.ultimafree.com
    XDNS1=ultimafree.com
     
  20. Homie2

    Homie2 Well-Known Member

    Joined:
    Dec 16, 2004
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    HEelp I NEED HELP! :eek:
     
Loading...

Share This Page