StevenC

Well-Known Member
Jan 1, 2004
252
0
166
A fatal error has occurred:

DB Error: connect failed

[line 108 of /usr/local/cpanel/base/horde/lib/Prefs/sql.php]

Details have been logged for the administrator.


hrmm? looked all over.
 

StevenC

Well-Known Member
Jan 1, 2004
252
0
166
fixed
 

StevenC

Well-Known Member
Jan 1, 2004
252
0
166
i tried to change the root password for mysql because it was still blank, and it didnt work so i ran

Reset Local MySQL Root Password


and went to horde and the error went away
 
Jan 22, 2004
5
0
151
failure to connect to DB

hi,

i am having the same problem

DB Error: connect failed
[line 108 of /usr/local/cpanel/base/horde/lib/Prefs/sql.php]
Details have been logged for the administrator.

my server is new and when i looked at the mySQL password setting as mentioned above, it was blank. i reset the password (leaving the pw field blank) and it restarted mySQL fine. when i tried to login to the horde account, i got the same error!

i repeated the steps except this time i added a password to the field, retried the login and got the same error.

this is happening to all my accounts, any ideas?

--mr360
 

StevenC

Well-Known Member
Jan 1, 2004
252
0
166
are you using the "Reset Local MySQL Root Password" function or the "Set MySQL Root Password" function
 
Jan 22, 2004
5
0
151
tried both

i think i may have done it in reverse. nontheless i am getting the same message.

-----

1st i 'reset local mySQL root password' and mySQL restarted successfully. i got the same horde error.

2nd i 'set root mySQL password' (which was blank) to an actual password, restarted mySQL successfully, got the same horde error.

3rd i 'reset local mySQL root password' again (thought maybe it needed to be a sequential thing) and restarted mySQL successfully, got the same error message.

ugh -mr360
 
Jan 22, 2004
5
0
151
better option for webmail

tell me this;

does anyone have a better solution for webmail customers?

i want to add a 'read webmail' link to my homepage, from there i want to launch another browser where the user can enter email login creditials and then access thier webmail.

this is probably an easy one.

--mr360
 

Izzee

Well-Known Member
Feb 6, 2004
469
0
166
Re: better option for webmail

Originally posted by [email protected]
...i want to add a 'read webmail' link to my homepage, from there i want to launch another browser where the user can enter email login creditials and then access thier webmail.

this is probably an easy one.

--mr360
<a href="https://123.123.123.123:2096/" target="_blank">Client Webmail</a> or
<a href="https://domain.com/webmail" target="_blank">Login to your webmail</a> or
<a href="https://domain.com/webmail" target="_blank"><img src="yourlinkimage.jpg" alt="click here to login to your webmail"></a>

etc.etc.
Https=2096
http=2095

You can do the same sort of thing to give a cPanel link.
Substitute in the above html:
https=2083
http=2082
Sustitute cpanel for webmail in the above html
HTH
 
Last edited:

macian

Member
Oct 17, 2002
12
0
151
Found a fix, for myself at least

the /etc/my.cnf file was set to create the mysql socket file in /tmp/mysql.sock instead of /var/lib/mysql/mysql.sock

I updated this and restarted mysqld and all was well.

-sean
 
Jan 22, 2004
5
0
151
a multiple fix

that link works great.

i miscommunicated my intentions :mad:

actually what i want to do is provide a 'read webmail' link for multiple customers (the ones who refuse to learn the /webmail login).

i don't know if there is a script or something that would achieve this?

--mr360 (mr180 at this point :D )
 

BenThomas

Well-Known Member
Feb 12, 2004
598
0
166
Houston, Texas USA
cPanel Access Level
Root Administrator
DB Error: connect failed
[line 108 of /usr/local/cpanel/base/horde/lib/Prefs/sql.php]
Details have been logged for the administrator.
You are likely missing the horde database

Try this:
[email protected] [~]# mysql horde
ERROR 1049: Unknown database 'horde'

If that looks familiar, then run the following:
[email protected] [~]# mysqladmin create horde
[email protected] [~]# /scripts/fullhordereset

That should do it.
 

neraath

Member
May 25, 2004
15
0
151
Aggieland, TX
Originally posted by cpanelben
You are likely missing the horde database

Try this:
[email protected] [~]# mysql horde
ERROR 1049: Unknown database 'horde'

If that looks familiar, then run the following:
[email protected] [~]# mysqladmin create horde
[email protected] [~]# /scripts/fullhordereset

That should do it.
This also fixed my issue! Thanks!
 

Dr. Bogger

Well-Known Member
Dec 21, 2003
95
0
156
Same here :D

Man, my cpanel installation is all messes up for some reason, i am working out the bugs now lol, and this was one of them.

Anything I can do that will maybe solve all my problems?

Like maybe reinstalling cpanel or something?

If so, how do I do it?

Thanks.
Sean.
 
Thread starter Similar threads Forum Replies Date
D Email 2
I Email 2
M Email 2
S Email 1
P Email 0