The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Horde-squirrelmail-roundcube DB error.

Discussion in 'E-mail Discussions' started by mail2sacp, Nov 17, 2008.

  1. mail2sacp

    mail2sacp Well-Known Member

    Joined:
    Feb 25, 2007
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    I have strange problem and did not found anything on google or anywhere.

    Actually the dbs of all this webmails(horde,squirelmail,roundcube) are already there on server and also mysql is working fine.

    But I am getting db error when I click one of this three.

    Following is the error of each webmail.
    -------------
    1) Horde.
    A fatal error has occurred
    DB Error: connect failed
    Details have been logged for the administrator.
    -------------
    2) Squirelmail
    Error:
    ERROR: Connection dropped by IMAP server.
    -------------
    3) RoundCube
    DATABASE ERROR: CONNECTION FAILED!

    Unable to connect to the database!
    Please contact your server-administrator.
    ---------------------------

    As per this errors there seems to be issue with database but don't have any idea were exactly we need to fix it.

    If anyone can help on this would be really really great and God Bless Him.

    Regards
    Mail2Sacp.
     
  2. lngtanseco

    lngtanseco Well-Known Member

    Joined:
    Jun 9, 2006
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Have you tried restarting MySQL service?

    WHM >> SQL Server (MySQL)

    You may also want to check if you have enough storage space.

    Code:
    # df -h
    Also, check the mysql log. Below code should give you the log file name.

    Code:
    ls /var/lib/mysql/*.err
     
  3. mak_the_admin

    mak_the_admin Member

    Joined:
    Aug 10, 2007
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Mysql is working fine and also enough free space is available.
     
  4. Snowman30

    Snowman30 Well-Known Member
    PartnerNOC

    Joined:
    Apr 7, 2002
    Messages:
    681
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    we have seen this occur on one of our servers running the latest CURRENT 11.24 release

    havent been able to find the cause yet however
     
  5. nerbonne

    nerbonne Well-Known Member

    Joined:
    Aug 19, 2007
    Messages:
    52
    Likes Received:
    1
    Trophy Points:
    6
    Here is what my mysql error file says. Note that there are no new entries newer than the 18th, but the problem still occurs and I just tried to login and an error was not written:

    081118 10:03:41 [Warning] Found invalid password for user: 'bedflixc@localhost'; Ignoring user
    081118 10:03:41 [Warning] Found invalid password for user: 'bedflixc_psadmin@localhost'; Ignoring user
    081217 8:00:14 [Warning] Found invalid password for user: 'naturest@localhost'; Ignoring user
    081217 8:00:14 [Warning] Found invalid password for user: 'naturest_psadmin@localhost'; Ignoring user
    081218 8:00:36 [Warning] Found invalid password for user: 'afterpar@localhost'; Ignoring user
    081218 8:00:36 [Warning] Found invalid password for user: 'afterpar_afterpa@localhost'; Ignoring user



    Also note that the server came up normally with no errors:

    081225 12:14:38 InnoDB: Starting shutdown...
    081225 12:14:40 InnoDB: Shutdown completed; log sequence number 0 189056493
    081225 12:14:40 [Note] /usr/sbin/mysqld: Shutdown complete

    081225 12:14:40 mysqld ended

    081225 12:14:40 mysqld started
    081225 12:14:40 InnoDB: Started; log sequence number 0 189056493
    081225 12:14:40 [Note] /usr/sbin/mysqld: ready for connections.
     
  6. sirotex

    sirotex Well-Known Member

    Joined:
    Jul 10, 2008
    Messages:
    121
    Likes Received:
    0
    Trophy Points:
    16
    It isn't MySQL, it's IMAP. I've been playing with Courier & Dovecot all day. Using courier in 11.24 it fails to start, but yet can connect to webmail. Dovecot however stays up etc but isn't converting the mail DB's correctly so you will be best using Courier, and moving to STABLE untill they fix it.
     
  7. nerbonne

    nerbonne Well-Known Member

    Joined:
    Aug 19, 2007
    Messages:
    52
    Likes Received:
    1
    Trophy Points:
    6
    I am running 11.23.2 STABLE. It appears as if you are saying this issue is caused by running RELEASE or CURRENT versions. If so, how can this issue be my issue?
     
  8. sirotex

    sirotex Well-Known Member

    Joined:
    Jul 10, 2008
    Messages:
    121
    Likes Received:
    0
    Trophy Points:
    16
    I never said this was a RELEASE/CURRENT issue, I did indeed say this is an IMAP issue. Anyways Dovecot is the problem if you're running Courier then it isnt the same problem. Basically just trying to fit everyone into the answer ;) Running Courier on 11.24 causes problems, thus people will need to run STABLE untill they fix the bugs
     
    #8 sirotex, Dec 25, 2008
    Last edited: Dec 25, 2008
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,450
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:

    Where did you read that?
     
  10. sirotex

    sirotex Well-Known Member

    Joined:
    Jul 10, 2008
    Messages:
    121
    Likes Received:
    0
    Trophy Points:
    16
    I didn't read it - There is problems running Courier on 11.24. I didn't bother checking error logs yet though instead went back to STABLE branch untill we have enough time.

    I'd be very intrested to know if you run cPanel 11.24 & Courier without any problems :)
     
    #10 sirotex, Dec 26, 2008
    Last edited: Dec 26, 2008
  11. nakuls77

    nakuls77 Member

    Joined:
    Jul 22, 2008
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    You need to check out the entries for your domains in /etc/localdomains as well as /etc/remotedomains

    A entry should exist but only in a single file of the 2 mentioned above depending upon the mail server the domain uses.

    Make sure you clear all the session files in /tmp and it does have adequate free space to create new sessions, once you've verified all these restart the IMAP service using /scripts/restartsrv_imap
     
  12. AlexandreVeezon

    AlexandreVeezon Well-Known Member

    Joined:
    Dec 9, 2005
    Messages:
    99
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    /br/sc/rionegrinho
    cPanel Access Level:
    Root Administrator
    Hi

    upcp --force didn't work here.
    courierup --force either

    Anyone finds a solution?

    Thanks :)
     
  13. cuongvttt

    cuongvttt Active Member

    Joined:
    Jun 26, 2008
    Messages:
    36
    Likes Received:
    1
    Trophy Points:
    6
    Use these command

    For Horde
    /usr/local/cpanel/bin/update-horde --force

    For SquirrelMail
    /usr/local/cpanel/bin/update-squirrelmail --force

    For Roundcube
    /usr/local/cpanel/bin/update-roundcube --force


    Enjoy it
     
Loading...

Share This Page