Horde User is not authorized for Mail

Wabun

Well-Known Member
Oct 6, 2012
89
5
8
Antwerpen
cPanel Access Level
Root Administrator
After the 74.0.10 update last night, a horde webmail user accounts is corrupted.
I deleted his mailbox after few hours struggling to understand what is exactly wrong, I decided to restart all services run about 4 times the /scripts/upcp --force, run the /usr/local/cpanel/bin/update_horde_config no result.
I decided to re-create his mailbox and was surprised with that the webmail user was again not authorized, but the mailbox had 53.4 mails in it according to Horde... wow... where the heck did he find those as nothing is in his account!!! Now 12 hours ago i re-created the mailbox, checked his account and still same situation, no access, mail in it, OK I thought I remove it manual in the email disc usage, logout, try roundcube, login failed, so we are stuck. I found somewhere only way to fix it is a hordereset script.

Please could you provide instructions in how to run the script and will it effect any other user?
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
7,995
645
263
Houston
cPanel Access Level
DataCenter Provider
Hi @Wabun

In most of the cases I've seen behavior like this it's because the user has been blocked in cPhulk. Can you tell me if you have cPhulk enabled and if so do you get anything useful by checking the cPHulk logs here:

Code:
/usr/local/cpanel/logs/cphulkd.log
or
Code:
/var/log/maillog
You'd want to search both of these for the email user
 

Wabun

Well-Known Member
Oct 6, 2012
89
5
8
Antwerpen
cPanel Access Level
Root Administrator
Hi, I checked in the first reporting if that was the case, but the user IP is whitelisted, and when I use the cPanel as WHM user same error comes up.
User is not authorized for Mail
 

Attachments

Wabun

Well-Known Member
Oct 6, 2012
89
5
8
Antwerpen
cPanel Access Level
Root Administrator
Tried this, according to your help page, but no success, the other 2 mailboxes in same account work fine!

mv /home/user/.cphorde/horde.sqlite /home/user/.cphorde/horde.sqlite.bak
/usr/local/cpanel/bin/update_horde_config --user=user --create-defaults

Starting update of 1 user in parallel …
(1 / 1)
------------------------------------------------------------------------
Summary:

Ran database checks on 1 account(s).

There were 0 accounts with failures during this process (see above):
n/a

There were 1 accounts successfully processed:
user

There were 0 accounts that did not need any work done:
n/a

/usr/local/cpanel/bin/update_horde_config --user=user --full

No result,

Also tried roundcube but this doesn't work either and is supposed in a different database if i am correct, so it seems creating a mailbox doesn't add the user in both databases with the correct access rights.

EDIT: Also found that there is still a horde database, shouldn't that be removed since all users are having their own SQlite db???

Creating a new email account works fine, so the issue seems to be this emailbox, deleting and re-creating doesn't solve the issue, any one out there with some experience how to fix this?
 
Last edited:

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
7,995
645
263
Houston
cPanel Access Level
DataCenter Provider
Hi, I checked in the first reporting if that was the case, but the user IP is whitelisted, and when I use the cPanel as WHM user same error comes up.
What I was really trying to ascertain here is if the mail user itself was blocked which is why I asked you to clear the cphulk blocks. Did you do this?

If you did or username blocking is disabled please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!