Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Host Access Control not saving

Discussion in 'Security' started by stus, Jan 24, 2013.

  1. stus

    stus Registered

    Jan 24, 2013
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator

    I was having trouble connecting to my server via SSH. It used to work alright, but I haven't tried connecting in a while.

    I then logged in to WHM and saw that ALL IP addresses are denied sshd access in the Host Access Control. I then added a rule to allow my IP address sshd access, but clicking "Save Host Access List" at the bottom simply reverts to the previous settings and ignores any changes.

    Any ideas what might cause this?

    Thanks for your help.
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello :)

    It's difficult to offer any troubleshooting advice if you do not have SSH access to the server. Have you tried recording the entries and removing all access restrictions from the option to see if you are able to then save the changes? Beyond that, you can modify the entries directly if you can obtain SSH access:

    # /etc/hosts.allow
    # /etc/hosts.deny

    Your data center may need to assist you if SSH access is not possible.

    Thank you.
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice