k2tec

Well-Known Member
Aug 26, 2011
104
5
68
Netherlands
cPanel Access Level
Root Administrator
I don't get mail from my vps.eq2.mydomain.nl

I set all my mail server contact
root mail :[email protected]
nobody's mail: [email protected]
cpanel's mail: [email protected]

I set the /root/.forward to [email protected] and I get the mail
echo "test" | mail -s "test" [email protected]

I saw a other thread and follwed this.
Code:
[email protected] [/etc]# cat /etc/localaliases
cpanel: [email protected]
nobody: [email protected]
root: [email protected]
Code:
[email protected] [/etc]# cat /var/cpanel/userhomes/cpanel/.forward
[email protected][/QUOTE]
[CODE][email protected] [/etc]# cat /root/.forward
[email protected]
Now the strange outcome the .com the [email protected] is only set in basic server setting
Enter one or more cellular phone or pager email addresses to message via email in case a problem arises with this server
Code:
[email protected] [/etc]# grep [email protected] /etc/valiases/*
/etc/valiases/mydomain.nl:[email protected]: [email protected]
Code:
[email protected] [/etc]# grep [email protected] /etc/vfilters/*
Nothing
Code:
[email protected] [/etc]# cat /etc/hosts
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
84.22.97.91 vps.eq2.mydomain.nl vps
Code:
[email protected] [/etc]# cat /etc/mail_reverse_dns
xx.xx.xx.91: vps.eq2.mydomain.nl
Code:
[email protected] [/etc]# exim -bt [email protected]
[email protected]
<-- [email protected]
<-- [email protected]
router = virtual_user, transport = virtual_userdelivery
[email protected]
<-- [email protected]
<-- [email protected]
<-- [email protected]
router = lookuphost, transport = remote_smtp
host mail.mydomain.com [xxx.xx.xxx.xx] MX=10
regards
Tom
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
I don't get mail from my vps.eq2.mydomain.nl
Have you checked /var/log/exim_mainlog to see if the email has been sent out, or if it's sending out to an alternate address?

Thank you.
 

k2tec

Well-Known Member
Aug 26, 2011
104
5
68
Netherlands
cPanel Access Level
Root Administrator
This is a part of my exim log
2014-03-06 20:02:19 1WLdYg-0001vt-Fa remote host address is the local host: vps.eq2.mydomain.nl
2014-03-06 20:02:19 1WLdYg-0001vt-Fa == [email protected] R=dkim_lookuphost defer (-1): remote host address is the local host
2014-03-06 20:02:19 1WLdYg-0001vt-Fa ** [email protected]: retry timeout exceeded
2014-03-06 20:02:19 1WLdYg-0001vt-Fa [email protected]: error ignored
2014-03-06 20:02:19 1WLdYg-0001w2-Vi <= <> R=1WLdYg-0001vo-84 U=mailnull P=local S=1704 T="Mail delivery failed: returning message to sender" for [email protected]
2014-03-06 20:02:19 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1WLdYg-0001w2-Vi
2014-03-06 20:02:19 1WLdYg-0001w2-Vi remote host address is the local host: vps.eq2.mydomain.nl
2014-03-06 20:02:19 1WLdYg-0001w2-Vi == [email protected] R=dkim_lookuphost defer (-1): remote host address is the local host
2014-03-06 20:02:19 1WLdYg-0001w2-Vi ** [email protected]: retry timeout exceeded
2014-03-06 20:02:19 1WLdYg-0001vt-Fa Completed
2014-03-06 20:02:19 1WLdYg-0001w2-Vi [email protected]: error ignored
2014-03-06 20:02:19 1WLdYg-0001vo-84 Completed
2014-03-06 20:02:20 1WLdYg-0001w2-Vi Completed
This is out of my Mail Delivery Reports
warning

[email protected]

6 mrt. 2014 20:03:20



[email protected]

1WLdZc-0001wM-0F

remote host address is the local host

Bekijk details
error

[email protected]

6 mrt. 2014 20:03:20



[email protected]

1WLdZc-0001wM-0F

retry timeout exceeded

Bekijk details
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Please check /etc/remotedomains to see if the hostname or domain name associated with it is added to this file.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Could you open a support ticket using the link in my signature so we can take a closer look? It will be easier to troubleshoot the issue by reviewing the actual configuration you have setup your system. Please post the ticket number here so we can update this thread with the outcome.

Thank you.