The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Host name reverts to old after recompilation, SSH problem results

Discussion in 'EasyApache' started by lumi, Nov 27, 2013.

  1. lumi

    lumi Registered

    Joined:
    Nov 26, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    After a recent hack intrusion my VPS provider did a fresh system reinstallation with WHM 11.40.0 (build 26). The first thing I did was rename the host from what they had set it up as to host.myhost.com. Then I restored the email for all 6 of my accounts, after which I started setting up their SSH keys. I set up keys for 2 accounts before I realized PDO hadn’t been enabled, so I enabled it with EasyApache. Then I continued setting up SSH keys for the remaining accounts, except they weren’t working. Permissions seemed to be fine and the keys were being generated, but I was getting the usual "No Supported Authentication methods available" message. After a while I realized that for some reason EasyApache had reset my host name to what it was after the fresh reinstallation before I renamed it! I was sure changing it back to host.myhost.com would fix the problem, but instead it just changed. Now I’m getting a “Wrong passphrase” error when entering the passphrase in WinSCP. The same thing happens with PuTTY. I tried deleting the key and generating a new one, paying attention to the passphrase, but no dice. The same passphrase that allowed me to convert the private key to .ppk format did not work when trying to connect. It would be great to not have to reinstall the remaining accounts!
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Have you tried accessing the server directly via the IP address? Also, what method are you using to modify the hostname? Is this a VPS? If so, make sure the new hostname is also configured at the VPS node level.

    Thank you.
     
Loading...

Share This Page