The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

hosted domain with outside mail server

Discussion in 'E-mail Discussions' started by wkdwich, Jun 19, 2005.

  1. wkdwich

    wkdwich Well-Known Member

    Joined:
    Apr 11, 2005
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    I am in the process of moving domain.com from the old tried Cobalt RAQ to this new server running Fedora core, EXIM 4.4 and Cpanel. I host the domain, while their mail goes to the company's main office mail server : mail.domain.com The 2 boxes physically sit in 2 different places.. I have no control over the mail server box

    On the Cobalt, I set the MX record to point to mail.domain.com and set NO USERS at all

    I'm a little confused as to how I go about this here.. At this point I just set up the domain this AM and will be transferring all their files in the next 2 days hoping to change the DNS record Sunday evening..

    the record looks like this on the RAQ:
    domain.com --> 216.40.000.000
    mail.domain.com --> 24.56.000.000
    www.domain.com --> 216.40.000.000
    216.40.000.000/24 --> www.domain.com
    domain.com --> mail is sent to the Very-High priority mail server mail.domain.com

    In the domain set up screens on thr RAQ's GUI it now looks like:
    Domain Name = domain.com
    Web Server Aliases = domain.com, www.domain.com
    Email Server Aliases = [BLANK]

    and like I said.. these are no users set up for this account.. oh sorry yes there is a webmaster account but honestly I don't even know if I ever got any mails from that!

    I'm hoping you or someone else can guide me here.. I have been scouring the forum for a little how to but what I have found confused me more, so I figured I'd ask..

    thanks..
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
  3. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    1. edit the DNS zone for domain,com
    2. enter the mail.theireofficedomin.com in th mx records

    3. in SSH
    pico /etc/localdomains and remove any trace domain.com
    pico /etc/remotedomains and add the domain here

    done
     
  4. wkdwich

    wkdwich Well-Known Member

    Joined:
    Apr 11, 2005
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    OK thanks.. these are the 2 I did find previous.. printed the 1st one and will read it again and walk thru the steps before implementing.. Hope you will be around today in case I have a problem! I have to get this one right and live tonight.. since I started to set up the new one, the office manager (Gerri) can not email an employee (Joann) who's account is on the same server under another domain and does not use the inhouse mail server, but instead pops the account on my server..

    I think the big question is users on this domain with the external mail server..
    I have no idea what alias' she has set up on the office inhouse server..

    EX: Gerri - the office manager for domain2.com emailed Joann - the employee of domain1.com
    The mail came back to Gerri:

    So to clarify..after I make the changes as described in that forum post, do I still need to setup an account for gerri@domain2.com?? How about any alias' ??
    Gerri's outlook is set to replyto gerri@domain2.com
     
  5. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    If you make the changes i posted above the mail is not controled by your server it is controlled by the other server, all aliias's & user accounts must be created on the other mail server
     
  6. wkdwich

    wkdwich Well-Known Member

    Joined:
    Apr 11, 2005
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    OK great thats what I thought.. can I still create a single user with an alias for webmaster then fwd that to another address which also resides onthe cpanel server..

    I just set the DNS and DNSReport already is showing it live.. keep your fingers crossed for me!
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    No, because you've told the MTA, exim, that the domain doesn't reside on the server. You might be able to use the cPanel account name to send an email, but I doubt it.
     
  8. wkdwich

    wkdwich Well-Known Member

    Joined:
    Apr 11, 2005
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    It's been 3 days now and this is still not working..

    dnsreport shows the site's IP not the mail server IP:
    mxtoolbox also shows the sites IP address not the mail server

    On Sunday 19th I set the record as everyone explained..
    mail.domain.com 14400 IN MX 0 IP_of_mail_server
    domain.com 14400 IN MX 0 mail.domain.com

    I removed the domain from localdomains and added it to remotedomains
    I set up no users on the system for this domian

    I printed the record after the changes were made..
    I see today looking at it again there was a:
    mail 14400 IN CNAME domain.com

    I asked the hosting people to take a look yesterday because this has not taken effect yet and the client is screaming

    this morning (Tues 21st) I see someone changed something here.. not sure who or when, my ISP has been having real bad mail issues themselves and I am sure I have lost mails..
    mail 14400 IN CNAME domain.com
    was changed to:
    mail 14400 IN A domain_IP

    So I just went in and changed that to show:
    mail 14400 IN A mail_server_IP

    Where did things go wrong here?? I have one more domain to move that also has its own mail server and can not afford for it to take 3+ days to propigate.

    A tech from the hosting place suggested I have the mailserver people set up a NEW ip and mail2.domain.com -- I asked him to email me the details exactly what he was explaining but I have not heard from him (could be my ISP mail problems)

    Would I have been better off setting up a single user as a catch-all and let the company POP that account until propigation happened THEN do the mail server switch maybe a week later???

    Thanks..
     
  9. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    Only thing you needed to change was the mx records

    If the off server mailser is broken then and you entered your MX records in correctly then this is not a Cpanel problem
     
Loading...

Share This Page