The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hosting provider upgraded PHP and now my website doesn't work

Discussion in 'General Discussion' started by the_Dsigner, Jan 3, 2014.

  1. the_Dsigner

    the_Dsigner Active Member

    Joined:
    Jan 2, 2014
    Messages:
    43
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Montreal, Canada
    cPanel Access Level:
    Website Owner
    I asked my hosting provider if it was possible to easily upgrade the server PHP version so I could run a new blogging platform that I found on the web. The original version was V5.2.x.x and the minimum for the platform I was looking at installing needed min 5.3. The hosting provider said it wouldn't be a problem and it was a straightforward install and it would be done over the holidays. Fast track to today and I find both my company's current website which is a static html page with php "require" calls for the navbar and a new Magento online store which I was working on in the background have both stopped working. The php require calls no longer bring up my navigation bar and when trying to access the magento site I get a 500 Internal server error. If I go into the cPanel and change the index.php permissions for the magento store from 666 to 664 the site comes back, but certain parts still don't work e.g: The thumbnails for the products listed which are called through scripts dont show up. My hosting provider is being very slow in responding to this big problem and I'm not sure what to do now?

    Any ideas? Thanks for your time. Happy New Year!
     
  2. Wabun

    Wabun Well-Known Member

    Joined:
    Oct 6, 2012
    Messages:
    56
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Antwerpen
    cPanel Access Level:
    Root Administrator
    Hi,

    Create a php.ini file in the / of the website [might need in more folders]

    content of php.ini file.

    display_errors = off
    error_reporting = E_ALL & ~E_NOTICE


    At least it should stop displaying the errors on the website, so you have time to update/fix your website to be compatible with newer php.

    File rights: Depending on how the server is configured, try for folders 755 and files 644.
     
    #2 Wabun, Jan 3, 2014
    Last edited: Jan 3, 2014
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    I suggest reviewing the full error logs for your website to determine the specific cause of the internal server error message. You can paste a snippet of the log output here for review.

    Thank you.
     
  4. the_Dsigner

    the_Dsigner Active Member

    Joined:
    Jan 2, 2014
    Messages:
    43
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Montreal, Canada
    cPanel Access Level:
    Website Owner
    Here is a taste of whats in my cPanel error log

    [Removed - Only File Not Found Errors]
     
  5. the_Dsigner

    the_Dsigner Active Member

    Joined:
    Jan 2, 2014
    Messages:
    43
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Montreal, Canada
    cPanel Access Level:
    Website Owner
    What do you mean fix to make compatible with newer php? The magento site I have running in the background was supposed to be compatible from V5.2 all the way to the latest. How does it go from working one min and errors the next?

    I have already switched the folder containing the magento site to permissions 755 and the index.php file is set to either 666 or 644 and it still doesn't work.

    permission644.png

    - - - Updated - - -


    [Fri Jan 03 09:49:06 2014] [error] [client 69.196.162.201] SoftException in Application.cpp:256: File "/home/thoughtt/public_html/new/index.php" is writeable by group
     
  6. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    This error:
    Code:
    [Fri Jan 03 09:49:06 2014] [error] [client 69.196.162.201] SoftException in Application.cpp:256: File "/home/thoughtt/public_html/new/index.php" is writeable by group
    
    tells that permissions of index.php are not correct.
    Make sure that all php files have permissions 644, and directories 755.

    If file's permissions are 664 it means it's "writeable by group" (as the error message states).
     
  7. the_Dsigner

    the_Dsigner Active Member

    Joined:
    Jan 2, 2014
    Messages:
    43
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Montreal, Canada
    cPanel Access Level:
    Website Owner
    How come this problem didn't show up with the previous version of PHP with the current permission settings?

    Thanks
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  9. the_Dsigner

    the_Dsigner Active Member

    Joined:
    Jan 2, 2014
    Messages:
    43
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Montreal, Canada
    cPanel Access Level:
    Website Owner
    I'm put the directory and all php files including index.php as permission 644 and it still is giving me errors.

    - - - Updated - - -

    [Fri Jan 03 13:47:55 2014] [error] [client 66.249.75.239] File does not exist: /home/thoughtt/public_html/protocol
    [Fri Jan 03 13:45:29 2014] [error] [client 66.249.75.193] File does not exist: /home/thoughtt/public_html/404.shtml
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Please ensure you only post the specific error messages related to the website error message. There is no need to post the full output with all "File Does Not Exist" error messages. It looks like you will have to receive assistance from your web hosting provider because the only errors from the error log you posted are for "File Does Not Exist" errors.

    Thank you.
     
  11. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator

    Those have nothing to do with file / directory permissions, seems like googlebot requesting file(s) that do not exist.
    They don't prevent your site from working.
     
  12. MesinHosting

    MesinHosting Member

    Joined:
    Mar 25, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    from reading from your posted. i have separated two different topic regarding to your problems.

    the first one you need and want to upgrade php version from php v.5.2 to php v.5.3. but it's cant be made by your host.
    second, i think you have a problem with file permission on your server.

    this typical question have different essential and has nothing the same one and other.

    for the first question. i suggest you to move from your old host to new host. now so many hosting were used cloudlinux os and find the fit one for you. on this typical hosting, you can choice your own php version. i guest now starting from php 5.2 to 5.5 at current momment. beside, cloudlinux much better and newer rather than old typical hosting os.

    and for the second question i think it's can be solved by runing
    [root]# chown youruserid:yourusergroup /path/yourfile.php

    or you can read the php manual about chown and chmod

    i hope it's will solved your problems
     
Loading...

Share This Page