Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

hostname alerts going to spam

Discussion in 'E-mail Discussion' started by jeffschips, May 15, 2018.

  1. jeffschips

    jeffschips Active Member

    Joined:
    Jun 5, 2016
    Messages:
    27
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    new york
    cPanel Access Level:
    Root Administrator
    My server email alerts which originate from root@hostname.domain.com always go to spam. My DNS is setup as:

    hostname.domain.com
    domain.com

    Yet emails from root@hostname.domain.com always end up in spam on the external email service that are receiving them.

    What is the preferred method for setting this up so alerts (originating from ConfigServer and identified as originating from hostname.domain.com) do no go to spam?

    Thanks.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,928
    Likes Received:
    1,819
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Are your root notifications configured for delivery to an external email account (e.g. Gmail, Hotmail)? If so, you may need to update the contact address to an email account on the local cPanel server, and then setup a filter or forwarder to forward the notification emails to that external address. I encourage you to vote for the following feature request if you'd like to see an option to configure SMTP authentication for the root notifications:

    Send cPanel Notifications via Authenticated SMTP Connection

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jeffschips

    jeffschips Active Member

    Joined:
    Jun 5, 2016
    Messages:
    27
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    new york
    cPanel Access Level:
    Root Administrator
    Hi cPanelMichael - I voted for your suggestion.

    I solved the problem by inputing, in ConfigServer csf.conf "from field for messages" the email address of a local account, and now all is fine. But I do support your recommendation to allow authenticated smtp connection via cpanel.

    Thank you.
     
    cPanelMichael likes this.
  4. jeffschips

    jeffschips Active Member

    Joined:
    Jun 5, 2016
    Messages:
    27
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    new york
    cPanel Access Level:
    Root Administrator
    I see that I tried voting but when attempting to vote it asks me for my login credentials, and I'm already logged in. Nevertheless, I input my current credentials and it won't log me in.

    How about a suggestion that allows people to vote on issues without having to login twice or then register to vote for something?
     
    cPanelMichael likes this.
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,242
    Likes Received:
    385
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You will need to register an account on the Feature Requests site to vote on a Feature. Your forum login is not connected to the site over there.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice