The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hostname and mail problem

Discussion in 'E-mail Discussions' started by gmyb16, Sep 16, 2014.

  1. gmyb16

    gmyb16 Registered

    Joined:
    Sep 16, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    hello, I have a problem

    recently change my hostname and from that I'm having problems with my email.

    If i access through cpanel accepts my username and password but then when directed to a mail handler (example: roundcube) says that the user is incorrect.

    The only way to fix it, is to add in /etc/userdomains

    my domain as follows:

    domain: userdomain

    It works OK, but only for a few hours, then domain disappears again.


    Someone can help me?

    Thank you
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you confirm that your new hostname is not added to any accounts on the server as a primary domain name or parked/addon domain name?

    Thank you.
     
  3. gmyb16

    gmyb16 Registered

    Joined:
    Sep 16, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi, hostname is added on the server as a primary domain name.


    Thanks
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    This is the problem. Your hostname must stand on it's own with no association to an account as a domain name. You can update your hostname to something like "server123.domain.com" to resolve the issue.

    Thank you.
     
Loading...

Share This Page