The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hostname - nobody@ problem.

Discussion in 'General Discussion' started by hergy80, Dec 8, 2005.

  1. hergy80

    hergy80 Well-Known Member

    Joined:
    Sep 4, 2004
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    I have 2 cpanel servers with the hostnames:

    server1.domain.com
    server2.domain.com

    server1.domain.com has the domain.com account setup on it. Everything is working except when I have a script send mail from server2.domain.com, it is getting "sender verify failed" for the nobody@server2.domain.com. How can I setup the e-mail account so that that sender exists?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    On the server with the authoritative zone (i.e. where the name servers are pointing to, presumably server1) for domain.com make sure that you do not have zone files for server1.domain.com or server2.domain.com (i.e. delete them if you have). Then make sure that the zone file for domain.com has two A records for server1 and server2 pointing to the correct IP addresses for each one.

    On server2, make sure that there are no zone files for server1.domain.com server2.domain.com or domain.com.
     
  3. hergy80

    hergy80 Well-Known Member

    Joined:
    Sep 4, 2004
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for the quick response. I had those zones present, so I removed them and make the A records in the DNS, and double checked server2, but I'm still getting the failed message from nobody@server2.domain.com.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    OK. Next, you ay have to wait for propagation. If no, then check that the hostname is listed in /etc/localdomains on the local server, the simplest way to ensure that is to run the following on both servers (though it ought to be there):

    /scripts/mailperm

    Lastly, make sure that you have a valid email address for nobody's email in WHM > Change System Mail Preferences.
     
  5. hergy80

    hergy80 Well-Known Member

    Joined:
    Sep 4, 2004
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    I made the dns changes yesterday, hoping they would propogate through the night. I ran the mailperm script but when I got to change the nobody e-mail, it says it is changed, but when I go back in it is blank. (Bug maybe?)
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Yes, that's a bug that's now fixed in the latest EDGE build. Check /etc/localaliases that nobody: is setup correctly.
     
  7. hergy80

    hergy80 Well-Known Member

    Joined:
    Sep 4, 2004
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Ok, it's in there. I guess maybe I should just wait a little longer to propogate. Would it matter though since they are the same machines that run the dns? I noticed it not working because I have a script e-mail when someone hits a page on one of my site. This e-mail (it's a php script -- so it is coming from nobody@server2.domain.com) and going to an e-mail that's been setup for quite some time on server1.
     
  8. hergy80

    hergy80 Well-Known Member

    Joined:
    Sep 4, 2004
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    I guess one other thing to mention is that it was working until mailscanner was installed. :D
     
  9. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Ah! Well, that changes everything. If we installed it for you, log a ticket on our helpdesk.
     
  10. hergy80

    hergy80 Well-Known Member

    Joined:
    Sep 4, 2004
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Sorry -- I just thought it was something on my end -- should have mentioned that first. I prefer to try to work things out on my own (with forum guidance of course) because usually I'll learn something along the way (even if it doesn't directly pertain to my problem!)

    I'll log a ticket :)

    Thanks.
     
Loading...

Share This Page