Hostname on port 80 redirects to wrong website

Patrik Johnsson

Registered
Dec 4, 2014
2
0
1
cPanel Access Level
Root Administrator
Hello, thanks for looking. If I enter the hostname minus :2083 or :2087 the domain redirects to what seems to be the first website installed, how do I prevent or change this?

It's only on one of my servers this happens, so unsure why.
 

dalem

Well-Known Member
PartnerNOC
Oct 24, 2003
2,980
156
368
SLC
cPanel Access Level
DataCenter Provider
you missing your hostname in you httpd.conf if its not there it will display what ever is first in the httpd.conf
rebuild apache and it should add it or just add it manually and run

/usr/local/cpanel/bin/apache_conf_distiller --update

<VirtualHost *>
ServerName your hostname
DocumentRoot /usr/local/apache/htdocs
ServerAdmin [email protected]
<IfModule mod_suphp.c>
suPHP_UserGroup nobody nobody
</IfModule>
UserDir disabled
</VirtualHost>
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello :)

Yes, first try rebuilding the Apache configuration file via:

Code:
/scripts/rebuildhttpdconf
Thank you.