Hostname Problems... POP and MRTG

stugster

Well-Known Member
Apr 16, 2002
74
0
306
Edinburgh, UK
cPanel Access Level
Root Administrator
I recently changed the hostname of my server from alpha.Tempest2.com to alpha.tempest2.com (this is likely unrelated however.).


A while later, I realised that a lot of my customers (other than those using the Tempest2.com) were no longer receiving POP mail. They could however send mail from the server - but not receive.

--------------------------------------------------
[email protected]
(generated from [email protected])
Unrouteable address
--------------------------------------------------
[email protected]
(generated from [email protected])
Unrouteable address
--------------------------------------------------

Why mail should be routed through the alpha.Tempest2.com domain is beyond me anyway. All I know, is that mail is no longer working, and when you send something to their e-mail addresses, it is bounced back with the above error.

Now, as soon as I realised this, I did the normal thing, changed hostname back to what it was - but this doesnt seem to have done anything (and anyway, the routed domain name is Tempest2 and not tempest2 - which was what i changed it to [lower case t]).

So I go on our little page for mrtg which calls upon server hostnames, and I find that it is now no longer working (for some bizarre reason).. here's the error for that:

========================================
[email protected] [/var/named]# env LANG=C /usr/local/mrtg-2/bin/mrtg /usr/local/mrtg-2/mrtg2.cfg
SNMP Error:
no response received
SNMPv1_Session (remote host: "alpha.tempest2.com" [69.44.104.128].161)
community: "tempestsnmp"
request ID: 861356470
PDU bufsize: 8000 bytes
timeout: 2s
retries: 5
backoff: 1)
at /usr/local/mrtg-2/bin/../lib/mrtg2/SNMP_util.pm line 487
SNMPGET Problem for ifInOctets.2 ifOutOctets.2 sysUptime sysName on [email protected]::::::v4only
at /usr/local/mrtg-2/bin/mrtg line 1835
WARNING: skipping because at least the query for ifInOctets.2 on alpha.tempest2.com did not succeed
WARNING: no data for ifInOctets&ifOutOctets:[email protected] Skipping further queries for Host alpha.tempest2.com in this round.
ERROR: Target[alpha.tempest2.com_2][_IN_] ' $target->[0]{$mode} ' did not eval into defined data
ERROR: Target[alpha.tempest2.com_2][_OUT_] ' $target->[0]{$mode} ' did not eval into defined data
========================================


Any ideas guys?