The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hostname redirects

Discussion in 'General Discussion' started by eatld, Aug 5, 2010.

  1. eatld

    eatld Member

    Joined:
    Jul 11, 2010
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Code:
    James,
    
    I have changed hostname of Parallels Plesk Sitebuilder to
    sitebuilder.eanameservers.com using the following command:
    
    root@crossroads [~]# sb_config --sb_hostname=sitebuilder.eanameservers.com
    --force_update_wscfg
    Creating webserver config
    Reloading apache
    CPanel detected. Run utils/cpanel.sh script or manually add
    /etc/httpd/conf/sites/zz011_sitebuilder.conf to Apache includes
    Logs saved to /usr/local/sitebuilder/tmp/sb_config-1008050527.log
    root@crossroads [~]#
    
    Also because the Sitebuilder configuration file was overwritten with the command
    above I added these directives into
    /usr/local/apache/conf/sites/zz011_sitebuilder.conf anew:
    
    --->8---
    <IfModule mod_suphp.c>
    suPHP_UserGroup nobody nobody
    </IfModule>
    ---8<---
    
    Also when you changed PHP configuration through cPanel, sqlite.so binary that I
    installed on theserver before was overwritten with original one. Parallels Plesk
    Sitebuilder requires SQLite extension version 2 with UTF-8 encoding support (please
    see
    Requirements to Host).
    
    Installed PHP module had encoding iso8859:
    
    root@crossroads [~]# php -i | grep ^SQLite
    SQLite Library => 3.3.7
    SQLite
    SQLite support => enabled
    SQLite Library => 2.8.17
    SQLite Encoding => iso8859
    root@crossroads [~]#
    
    Parallels Plesk Sitebuilder could not work with it:
    
    root@crossroads [~]# curl -s
    http://sitebuilder.crossroads.eaname....com/check.php | grep -v OK
    <b style='color: orange'>WARNING</b> : <b>SQLite UTF-8 encoding</b> not found
    (current is <b>iso8859</b>)<br>
    root@crossroads [~]#
    
    To fix the problem I executed sqlite.so from php-sqlite2-5.2.4-0.93988.x86_64 and
    replaced file /usr/local/lib/php/extensions/no-debug-non-zts-20060613/sqlite.so with
    it. Original file was renamed to sqlite.so.bak and saved in the same directory:
    
    root@crossroads [~]# ls -l
    /usr/local/lib/php/extensions/no-debug-non-zts-20060613/sqlite.so*
    -rwxr-xr-x 1 root root 360608 Aug 5 05:25
    /usr/local/lib/php/extensions/no-debug-non-zts-20060613/sqlite.so*
    -rwxr-xr-x 1 root root 1307195 Jul 16 21:05
    /usr/local/lib/php/extensions/no-debug-non-zts-20060613/sqlite.so.bak*
    root@crossroads [~]#
    
    Parallels Plesk Sitebuilder works normally through the server now:
    
    root@crossroads [~]# curl http://sitebuilder.eanameservers.com/check.php
    <b style='color: green'>OK</b> : supported version of PHP found (5.1.X or newer -
    5.2.9)<br>
    <b style='color: green'>OK</b> : extension <b>sitebuilder3</b> in state <b>on</b>
    found<br>
    <b style='color: green'>OK</b> : extension <b>pdo</b> in state <b>on</b> found<br>
    <b style='color: green'>OK</b> : extension <b>pdo_mysql</b> in state <b>on</b>
    found<br>
    <b style='color: green'>OK</b> : extension <b>sqlite</b> in state <b>on</b> found<br>
    
    However the hostname sitebuilder.eanameservers.com is not resolved from outside,
    probably this is due to long propagation time of DNS zone (it may take up to one day
    for DNS records to propagate).
    
    Also it was found that request to http://sitebuilder.eanameservers.com/Admin is
    redirected to http://sitebuilder.eanameservers.com/Wizard. This is not normal.
    Kindly verify configuration of redirects in cPanel.
    I will monitor the server and continue configuration after the hostname becomes
    resolvable.
    
    Best regards,
    
    -- 
    Anastasia Bezborodova
    Technical Support Engineer
    Parallels 
    
    
     
    #1 eatld, Aug 5, 2010
    Last edited by a moderator: Aug 5, 2010
  2. eatld

    eatld Member

    Joined:
    Jul 11, 2010
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    re:

    Alright this is what parallels said I need to do So any help for me to understand and do it would be appreciated:


    James,

    Hostname sitebuilder.eanameservers.com is now resolved to IP address 74.54.58.90
    now. In the following page you may see that all requirements of Parallels Plesk
    Sitebuilder are satisfied: http://sitebuilder.eanameservers.com/check.php

    However due to specific configuration of Apache Web Service (mod_rewrite) all pages
    are registered to Wizard and I cannot login to Parallels Plesk Sitebuilder to finish
    configuration.

    I was unable to reconfigure mod_rewrite on the server, most likely it should be
    configured through the cPanel GUI. Kindly check the configuration and disable
    rewriting for Parallels Plesk Sitebuilder virtual host
    sitebuilder.eanameservers.com.


    I ASKED IF HE WANTED ME TO TURN OFF MOD REWRITE AND HE SAID:


    James,

    This is not necessary to disable mod_rewrite completely, but reconfigure the policy
    does not work for Parallels Plesk Sitebuilder hostname
    sitebuilder.eanameservers.com.
    I am not sure if this is possible configuring through cPanel, but this is required
    for normal work of Parallels Plesk Sitebuilder.


    THEN I ASKED FOR THE COMMAND LINE TO DO SO AND GOT THE FOLLOWING RESPONSE:


    James,

    The reconfiguration cannot be accomplished through the command line.
    Kindly contact cPanel support for assistance.



    I am clueless of what to do or where to go for this and any help would be appreciated.




    How do I go about checking a redirect for the server HostName I never did a redirect for the server hostname itself.
     
    #2 eatld, Aug 5, 2010
    Last edited: Aug 6, 2010
  3. eatld

    eatld Member

    Joined:
    Jul 11, 2010
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    re:

    I fixed this issue thanks for your help!

    Mods please close this thread.:D
     
Loading...

Share This Page