The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hostname SSL Install

Discussion in 'General Discussion' started by compunet2, May 5, 2010.

  1. compunet2

    compunet2 Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    310
    Likes Received:
    0
    Trophy Points:
    16
    I purchased and installed a SSL certificate for my hostname, so users can login to cpanel & WHM without getting the annoying "This Connection is Untrusted" message. I installed it without an issue (using user 'nobody') and when I goto https://hostname.domain.com it shows a valid certificate. However, when I goto https://hostname.domain.com:2083/ (or 2087) it gives me the "This Connection is Untrusted" message. How can I fix this?
     
  2. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    The SSL certificate used for cPanel, WHM and Webmail is different from the certificates you install for use with your Web sites. It appears that you only installed the certificate for use by Apache, which will not affect cPanel/WHM/Webmail. To use it for cPanel/WHM/Webmail, you will need to use Main >> Service Configuration >> Manage Service SSL Certificates in the WebHost Manager.

    The same type of SSL certificate can be used for your Web sites and for the services listed in Manage Service SSL Certificates, but since these are separate services, the certificate must be installed separately for each service.

    Note that there can only be one certificate each for cPanel/WHM/Webmail, POP/IMAP, SMTP and FTP. This is different from Web sites, in which case each site on its own dedicated IP address can have its own certificate.

    You may also need to adjust the setting for "When visiting /cpanel or /whm or /webmail with SSL, you can choose to redirect to" in Main >> Server Configuration >> Tweak Settings. Select either "SSL certificate name" or "Hostname" to avoid seeing a browser pop-up about a domain-name mismatch when accessing these services.

    More information about this subject is available in our documentation:

    Manage Service SSL Certificates
     
  3. davy

    davy Registered

    Joined:
    Apr 13, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Are there any other steps that are needed to activate a new SSL cert for CPanel/WHM/Webmail when installing a new one?

    I have purchased a new cert and clicked the "Install new Certificate" option and that all completes correcty (shows cert as Self Signed: No and shows the cert type as the new REAL one).

    However, when I go to https://server.domain.dom:2087 it still is using the old "self signed" default cert. Is there a step missing? I restarted Apache but not working still. So it appears like its gone to plan but the old cert is still there.

    I have removed my browsers cache for the accepted self signed cert previously used so It shouldnt be releated to that.

    Any ideas?
     
    #3 davy, Jun 24, 2010
    Last edited: Jun 24, 2010
  4. cPanelJamyn

    cPanelJamyn Social Engineer
    Staff Member

    Joined:
    Jan 29, 2009
    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    0
    Hi,

    The cPanel/WHM services are not tied to apache; they run as their own process, and although this step should not be necessary - manually restarting the cPanel/WHM service should ensure the new certificates are used. If that's not happening in your case, I recommend opening a support ticket, and attaching the full certificate bundle (cert, ca cert, key) to the support ticket (or including a link to the file) so we can take a look. Thanks!
     
Loading...

Share This Page