Hotlink Enabled - Printing Problem

NeilPhoenix

Member
Jun 4, 2007
6
0
151
Hello! This is my first post here so I hope I am in the right area.

As a result of discovering a large number of hotlinks to our site, I have recently enabled hotlinks in CPanel. I thought everything was working well until I started getting calls from our clients saying that the images are now not appearing on pages they print. I did not anticipate this as a consequence of enabling hotlinks. Am I doing something wrong? Is there a work-around for this?

Thank you for any help you can provide!
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,482
35
208
cPanel Access Level
DataCenter Provider
Hello! This is my first post here so I hope I am in the right area.

As a result of discovering a large number of hotlinks to our site, I have recently enabled hotlinks in CPanel. I thought everything was working well until I started getting calls from our clients saying that the images are now not appearing on pages they print. I did not anticipate this as a consequence of enabling hotlinks. Am I doing something wrong? Is there a work-around for this?

Thank you for any help you can provide!
Check the allow direct request box.
 

NeilPhoenix

Member
Jun 4, 2007
6
0
151
Thank you for your quick response. Correct me if I am wrong but I interpreted that box "Allow direct requests (ie. entering the url to an image in your browser)" to mean that anyone with the exact url would be able to circumvent the hotlink protection. Is that not the case?

Thank you.