The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

hotlink error

Discussion in 'General Discussion' started by koby59, Dec 29, 2009.

  1. koby59

    koby59 Member

    Joined:
    Dec 29, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    can't enable the hotlink.. when I'm pressing enable - its show me an error about rewriting and apatch.
    [may it cause because I have free version? ]

    Thank you.
     
  2. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    No, it has nothing to do with the free version, something is definitely missing. Provide some more information OR have someone look into it.
     
  3. koby59

    koby59 Member

    Joined:
    Dec 29, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    what do you mean?

    someone look into this?

    here is the error message after 1 click on the 'Enable' button:
    HotLink Protection
    There was an error while enabling hotlink protection. Show Details


    and this is the show details box:
    Apache detected an error in the Rewrite config.
    Please try again. Apache detected an error in the Rewrite config.
    Please try again.


    Thank you.
     
  4. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    I mean either your Hosting company OR cPanel support.

    Check if the .htaccess file under the account have correct ownership/permissions.
     
  5. koby59

    koby59 Member

    Joined:
    Dec 29, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    where is it

    can you direct me to it please?
    Thank you.
     
  6. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Do you have a Shared account with the hosting company OR you have your own dedicated server?
     
  7. koby59

    koby59 Member

    Joined:
    Dec 29, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    just a free acount I've opend yesterday to host some of my xml,html files.
    it has no contact to my local libraries.
     
  8. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    if you have a cPanel account, check the .htaccess file from cPanel >> File Manager option. The ownership of the file should be user:user, where 'user' is your cPanel username.

    If you are not able to figure it out, contact your hosting company as they are the one who can make changes from the server.
     
  9. koby59

    koby59 Member

    Joined:
    Dec 29, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    in the file manager I have :
    public_html
    mail
    tmp [ folder ]

    where should I go from here? [by the way I'm using windows XP]
    Thank you.
     
  10. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    You have to check under "public_html" directory.

    BTW, is this the only error message you received on clicking "Show Details:

    Didn't it displayed any filename and the line number where the problem is?
     
  11. koby59

    koby59 Member

    Joined:
    Dec 29, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    on the public html there is only a file name 'demo.html'
    by the way, on the appatch version its says 'unknown' it may be a part of the problem?

    and yes, thats the only error I get.
     
Loading...

Share This Page