The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

hotlink proection and Outlook (Express) / Hotmail

Discussion in 'E-mail Discussions' started by Berbox, Feb 1, 2007.

  1. Berbox

    Berbox Well-Known Member

    Joined:
    Apr 4, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Belgium
    Hello,

    I had a problem with displaying an HTML-email in Outlook (Express) and Hotmail. Thunderbird displayed the mail correct. For other email-clients I don't know if it will be displayed correctly.

    The images in the clients were not loaded. After a few hours we noticed that hotlink protection caused to not dislay the images. The image-paths were all relative and we tried also absolute.

    The domain that hosts the images was added to the hotlinking domains.

    Solution:
    When I selected the option "Allow direct requests" the images were correctly displayed.

    But why is there a difference between Outlook and Thunderbird in the method for displaying images in email
    ??
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    HotLink protection is based upon the setting of the Referrer attribute. Thunderbird is apparently setting this attribute, but OE/Hotmail are not.
     
  3. Berbox

    Berbox Well-Known Member

    Joined:
    Apr 4, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Belgium
    thanks for the explanation cpanelkenneth
     

Share This Page