The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hotlink protection redirect not working

Discussion in 'General Discussion' started by Framwinkle, Apr 4, 2004.

  1. Framwinkle

    Framwinkle Registered

    Joined:
    Apr 4, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    I can get the hotlink protection itself to work, and have successfully stopped people from leaching pictures from my website. The exemptions are also working fine.

    However, no matter what I do, it refuses to propperly redirect the leachers to the picture I specify in the redirect box. I've even tried rewriting the .htaccess file using the form I found on http://www.htmlbasix.com/disablehotlinking.shtml with no results. Is this something happening to everyone, and will it be fixed? Is there a way to fix it now? I'd appreciate any help.
     
  2. Framwinkle

    Framwinkle Registered

    Joined:
    Apr 4, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    I know of at least one other person having this same problem, so I know it's not just me. From what little I know now about the .htaccess file, everything seems to be written right the last time I looked at it. So does anyone know what's going on?
     
  3. Framwinkle

    Framwinkle Registered

    Joined:
    Apr 4, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    The only time I can seem to get it to work is if I go to one of the pages that is trying to leech one of my images, copy the URL to the picture, paste that URL in the address bar of my browser, and then while it's waiting to load go to the cPanel Hotlink Protection, check the Allow direct requests box and hit activate. As soon as I do that then the browser that was trying to load the image is imediately redirected to the image I want.

    But that's the only way it'll happen. The Allow direct requests box has to be unchecked before, and then rechecked during a download. Otherwise all you see is the broken image marker whether the Allow direct requests box is checked or not.
     
Loading...

Share This Page