The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

hotlinking errors

Discussion in 'Security' started by robotman321, Sep 8, 2008.

  1. robotman321

    robotman321 Registered

    Joined:
    Sep 8, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    well, when i activate my hotlinking protection on my account that i have with hostmonster, it seems to work fine for me, i can view the video files, but a few hours after i got a support message from a loyal viewer saying he couldn't view the episodes even tho they were on the site?!

    my build: 11.23.4-RELEASE
    this guy that sent me the message is coming from Singapore, and he was telling me that he was watching them fine on the site yesterday before i enacted the hotlinking protect on. He said he now gets a 403 error when he tries to view it on my site ?!

    is this a glitch with the program? because this isnt the first time and i really need answers so i can resolve this and re-enable it...

    any and all help is GREATLY appreciated.
    `Brad
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    This functionality typically works by analyzing one's HTTP_REFERER (sic.). If that user is using a browser add-on that masks this information, that could interfere with this functionality and cause the issue you mentioned.
     
  3. robotman321

    robotman321 Registered

    Joined:
    Sep 8, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    ah that makes sense, ill have to contact this guy and see if hes got any addons working...
     
  4. robotman321

    robotman321 Registered

    Joined:
    Sep 8, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    im re-bumping this is it possible that a persons ISP could do this? i know it has to do witht he HTTP_REFERER... but i have a friend that lives in canada he is attempting to view my files legit, but continues to get a 403 error.. he says he has no addons and JUST upgraded his FF to 3.0.3.. so this is confusing me.. royaly..
     
Loading...

Share This Page