The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hotmail Problems

Discussion in 'E-mail Discussions' started by Rahxie, Feb 9, 2011.

  1. Rahxie

    Rahxie Member

    Joined:
    Aug 21, 2005
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I'm having problems with my server where some hotmail emails aren't being received on the server. This is causing some issues for a client and hotmail aren't being helpful at all.

    I've checked email logs as well as tailed the log files when sending emails from this particular hotmail account, but nothing seems to show up when sending emails from this address. I can send emails to this hotmail account but not receive any emails from it to any account on the server.

    Log files I've been checking during and after sending emails:
    /var/log/exim_mainlog
    /var/log/exim_rejectlog
    /var/log/exim_paniclog
    /var/log/maillog
    /var/log/messages

    I've checked the servers IP against blacklists and also checked the MX records are all set up correctly, which they are and the servers IP is not blacklisted. The error code coming back in hotmail is (note: this "status" only ever appears when sending emails from this email address and another one similar to it. Both email addresses have the word "income" in them):
    Action: failed
    Status: 4.4.7

    The above status appears with and without SpamAssassin being enabled. I've also disabled the firewall when sending emails just in case that was the issue.

    As you can see, I've tried all sorts to get this sorted but contacting hotmail only ever gets "see this article" responses, which isn't helpful. If anyone can think of a way to resolve this or even additional things to try, please let me know.

    Thanks for taking the time to read this thread and hopefully this can be resolved soon. :)
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello,

    Please run the following command and provide the results:

    Code:
    exim -bs -d
    ehlo mx3.hotmail.com
    mail from: youruser@hotmail.com
    rcpt to: test@yourdomain.com
    DATA
    Subject: Test
    Test.
    .
    Replace youruser@hotmail.com with the actual hotmail email account you are using. Replace test@yourdomain.com with the email account on the cPanel server that you want to have receive the email. Please create a new test account for this email before performing the test. I am selecting a new test account so exim logs won't have other attempts in the log for the email account to make it easier to find the right log entry.

    Please note that these commands would need to be run in root SSH and all the noted commands are required to complete it (so the final . on the last line must terminate the session for exim).

    After doing the above commands, then please run the following command:

    Code:
    exigrep test@yourdomain.com /var/log/exim_mainlog
    Please note the results for the exigrep here.

    Thanks.
     
  3. Rahxie

    Rahxie Member

    Joined:
    Aug 21, 2005
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    When running the command exim -bd -d I get the following error until it eventually stops retrying:

    Code:
    11140   socket bind() to port 25 for address (any IPv4) failed: Address already in use: waiting 30s before trying again (9 more tries)
    
    Output of netstat:
    Code:
    root@thunder [~]# netstat -lnp | grep 25
    tcp        0      0 0.0.0.0:25                  0.0.0.0:*                   LISTEN      20633/exim
    
    I've tried restarting exim but same error as above appears, although exim starts with no errors and sending/receiving emails the usual way (webmail/thunderbird etc) seems to work.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Ah, I apologize, I miscopied and it is exim -bs, so try this instead:

    Code:
    exim -bs -d
    ehlo mx3.hotmail.com
    mail from: youruser@hotmail.com
    rcpt to: test@yourdomain.com
    DATA
    Subject: Test
    Test.
    .
    I'll revise my earlier post to have the right command for exim. Apologies again on the wrong character there for exim command line.
     
  5. Rahxie

    Rahxie Member

    Joined:
    Aug 21, 2005
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    No problem and thanks for your help. Here's the output after sending a mail, which seemed to send/receive with no problems:

    Code:
    2011-02-11 13:09:51 1Pnsko-0004va-50 <= increasemyincome@hotmail.co.uk U=root P=local-esmtp S=370 T="Test" for tmail@jslane.net
    2011-02-11 13:09:52 1Pnsko-0004va-50 => tmail <tmail@jslane.net> R=virtual_user T=virtual_userdelivery
    2011-02-11 13:09:52 1Pnsko-0004va-50 Completed
    
    I've just tried sending directly from hotmail to this same email address (tmail@jslane.net) after this, but still nothing seems to come through.
     
Loading...

Share This Page