The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How can I check what Apache compiled with?

Discussion in 'EasyApache' started by simplestar, Jan 23, 2006.

  1. simplestar

    simplestar Well-Known Member

    Joined:
    Nov 15, 2005
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    How can i confirm what Apache is compiled with? I just got through upgrading to php 4.4.2. problem is, I'm not sure if I checked off the OpenSSL Support Module. Also, if i didn't, do I really need it? Thanks
     
  2. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    make a phpinfo page

    <?php
    phpinfo();
    ?>
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Yup. Or from shell:

    php -i

    php -i | grep -i openssl
     
  4. simplestar

    simplestar Well-Known Member

    Joined:
    Nov 15, 2005
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    6
    Thanks :) Alright, I had to re-compile Apache for the OpenSSl support then I went into shell to check. Yep, PHP is installed but I don't see PHPSuExec or should I? Sorry, I only recently started using the PHPSuExec. Below is what I got out of the logs after the install. Is there anything else I should do? thanks for your help everyone.


    PHP:
    PHP 4.4.2 (cli) (builtJan 23 2006 12:39:54)
    Copyright (c1997-2006 The PHP Group
    Zend Engine v1.3.0
    Copyright (c1998-2004 Zend Technologies
        with Zend Extension Manager v1.0.8
    Copyright (c2003-2005by Zend Technologies
        with Zend Optimizer v2.5.10
    Copyright (c1998-2005by Zend Technologies

    /scripts/findphpversion
    eAccelerator requires Zend Engine API version 20021010.
    The Zend Engine API version 20050606 which is installed
    is newer.
    Contact eAccelerator at http://eaccelerator.sourceforge.net for a later version of eAccelerator.
     
Loading...

Share This Page