The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How can I update libdb & db.h?

Discussion in 'General Discussion' started by UpsideOut, Oct 22, 2003.

  1. UpsideOut

    UpsideOut Member

    Joined:
    Feb 4, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I have a CGI script running under mod_perl which uses BerkeleyDB. When run in debug mode, it errors out complaining "BerkeleyDB needs compatible versions of libdb & db.h". I have db.h version 3.3.11 and libdb version 2.4.14 now. I have tried searching the usual forums and Google.

    This is a dual Xeon running RedHat 7.3, WHM 8.5.4, cPanel 8.5.4-R7. BerkeleyDB was installed via the Perl Module Installer in WHM. And FWIW, this server is hosting just one site and this script is a major part of that.

    How can I update libdb & db.h or otherwise get BerkeleyDB to function?

    Any help would be much appreciated. Thank you.
     
Loading...

Share This Page