The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

how do I change EXim's sending IP?

Discussion in 'E-mail Discussions' started by SoftDux, Aug 6, 2008.

  1. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    983
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    Hi all

    I would like to change the IP address that Exim uses to send out emails, how do I do that?
     
  2. mohit

    mohit Well-Known Member

    Joined:
    Jul 12, 2005
    Messages:
    553
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sticky On Internet
    this should be possible if you allocate the sending account a dedicated IP.
     
  3. cpaneljoshb

    cpaneljoshb Registered

    Joined:
    Aug 6, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hello,

    mohit is correct given the new feature in CPanel which you can enable via tweak settings in WHM. Just enable the setting, and give them a dedicated IP. Make sure, that the dedicated IP has RDNS setup too :)
     
  4. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    Hi,

    I'm looking in tweak settings and I cant find an option to make exim send mail from a domain's dedicated IP if customer has one.

    Can you point this out to me pls.

    I'm on latest RELEASE build.
     
  5. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    It's in the Exim Configuration Editor interface:

    Send outgoing mail from accounts ip address instead of the main ip address. [Warning: If you turn this setting on you should make sure your reverse dns entries match the ones in /etc/mail_reverse_dns]
     
  6. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    Ahah! Thanks.
     
  7. jdsilva

    jdsilva Member

    Joined:
    Dec 27, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    What about the domains created with main IP?

    So another option is

    Disable the option
    "** Send outgoing mail from accounts ip address instead of the main ip address. [Warning: If you turn this setting on you should make sure your reverse dns entries match the ones in /etc/mail_reverse_dns] [?]" in WHM >> Service Configuration >> Exim Configuration

    Now edit exim.conf

    Comment the line "interface = ${if exists {/etc/mailips..." under "remote_smtp:"
    and add

    interface = <IP>

    Do the same in "dk_remote_smtp" too.
     
Loading...

Share This Page