The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How do I configure email to send from nobody account correctly.

Discussion in 'E-mail Discussions' started by Brook, Apr 28, 2005.

  1. Brook

    Brook Well-Known Member

    Joined:
    Apr 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    Hi

    I recently sent out a mailer from my forums however a large proportion were sent back to me with the error:

    <nobody@myhostname.mydomainname.com>... Sender domain must exist

    I thought I read somewhere that I need to configre exim to send email from just mydomainname.com and not myhostname.mydomainname because mydomainname.com will have an mx record and myhostname.mydomainname will not.

    Any ideas on how to do this tho?

    thanks.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That's not true. You need to make sure that:

    1. You do not have WHM > Tweak Settings > Prevent the user 'nobody' from sending out mail to remote addresses

    2. That you do have a valid email address in WHM > Change System Mail Preferences
    > nobody's email

    3. That you have an A record for your hostname in the authoratitve zone for your domain (i.e. that servername.domain.com has a correct A record in the zone file for domain.com)

    4. That servername.domain.com exists in /etc/localdomains

    alternatively, recompile apache/php with phpsuexec enabled ;)
     
  3. Brook

    Brook Well-Known Member

    Joined:
    Apr 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    Hi Chirpy - thanks for the reply.

    I have checked 1) and 2) and they are as you specified.

    However how do I check number 3): ?

    "That you have an A record for your hostname in the authoratitve zone for your domain (i.e. that servername.domain.com has a correct A record in the zone file for domain.com)"

    I have checked number 4):

    "That servername.domain.com exists in /etc/localdomains "

    And it is ok.

    If I enable phpsuexec, will my forum emails etc stop working? How will it effect contact forms etc? Its just that I've heard it can cause problems? Sorry Im a bit of a nube :)
     
  4. Brook

    Brook Well-Known Member

    Joined:
    Apr 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    P.s for: That you do have a valid email address in WHM > Change System Mail Preferences
    > nobody's email

    I have nobody1@mydomain.com and for that domain I have a default address info@mydomain.com - does the email (where I have nobody1@) have to be an actual email thats been set up in the cp?
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    An alias should be fine.

    You do need item 3. as that's the most likely cause of the problem. If you use your server for DNS and have nameservers configured for the server and you host yourdomain.com on the server, then in WHM > DNS > Edit DNS Zone > yourdomain.com > make sure that you have an A record for servername.yourdomain.com. pointing to the main IP address.

    There can be issues with enabling phpsuexec (check the forums).
     
  6. Brook

    Brook Well-Known Member

    Joined:
    Apr 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    ok so now I have added this:

    hostname.mydomain.com. 14400 IN A 18.55.170.47

    Is there anyway to check that everythings ok? Im so worried my server will stop working!!
    (sorry to be a chicken as well as a nube!)

    Do I need to restart anything? or does it do it automatically?

    thanks again for your help and bearing with me :)
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That should be all you need to do. It may take a while for some other servers to see the change (as DNS is propagated - usually around 24 hours) but you could try testing it out buy filling in a web-based email form that sends off-server and see if it now works.
     
  8. Brook

    Brook Well-Known Member

    Joined:
    Apr 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    Thanks!

    I've sent out a test and hopefully it works!
    (if you don't hear back from me on this thread it did! :))
    Thanks again for your help!
     
Loading...

Share This Page