The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How do I enable mod_proxy_fcgi for Apache 2.4?

Discussion in 'EasyApache' started by Simsim, Mar 22, 2013.

  1. Simsim

    Simsim Member

    Joined:
    Jan 25, 2012
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    How do I enable mod_proxy_fcgi for Apache 2.4?

    Regarding the instructions here:
    EasyApache: Raw Opts (Custom Configure Flags)


    I tried create a file:

    /var/cpanel/easy/apache/rawopts/Apache2_4

    that contain the following line:

    --enable-proxy-fcgi=static

    also I tried other variations:

    --with-proxy-fcgi=static
    --with-proxy_fcgi=static


    But nothing happen, I didn't find mod_proxy_fcgi in the list of modules with httpd -l command. It seems that EasyApache does not even look into the file /var/cpanel/easy/apache/rawopts/Apache2_4

    Help please, I am searching for a solution since hours

    thanks
     
  2. cPanelKevinS

    cPanelKevinS Member
    Staff Member

    Joined:
    Mar 7, 2013
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi Simsim,

    This is a bug in our Apache 2.4 code; the software looks for the wrong filename. We have opened Case 64298 to correct the problem.

    For now, you can work around this by putting the same information in /var/cpanel/easy/apache/rawopts/Apache2_2. The first version you used, --enable-proxy-fcgi=static, is the correct one. If you include the same option in both Apache2_2 and Apache2_4 files, it should continue to work correctly once we fix the problem.

    (This actually should not cause any problem if you try building Apache 2.2, despite the fact that 2.2 does not include mod_proxy_fcgi, because Apache's configure command silently ignores any options it doesn't recognize.)
     
  3. Simsim

    Simsim Member

    Joined:
    Jan 25, 2012
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Oh .. What about the 5 hours that I spent in debugging the problem and to work around by installing mod_proxy_fcgi using apxs tool haha .. any way .. thank you and please remove that line from the documentation until fixing the problem since many people need Apache 2.4 only to use mod_proxy_fcgi and php-fpm

    Also if you add mod_proxy_fcgi among the list of modules in easyapache, this will be really fine and great and you will be then the coolest guys found ever on the planet
     
Loading...

Share This Page