The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How do I get rid of nobody in emails from server?

Discussion in 'E-mail Discussions' started by Daveft, Jun 2, 2007.

  1. Daveft

    Daveft Registered

    Joined:
    Jun 2, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hey. This is the header in emails I get from the server.
    Is there anyway to get rid of the nobody in the header?
    Thanks.
    Dave.
    P.S. CPanel has really helped with server maintenance.


    Return-path: <admin@hft.com>
    Envelope-to: admin@hft.com
    Delivery-date: Sat, 02 Jun 2007 10:26:16 -0400
    Received: from nobody by admin.mainhft.com with local (Exim 4.63)
    (envelope-from <admin@hft.com>)
    id 1HuUYa-0006Ln-2V; Sat, 02 Jun 2007 10:26:16 -0400
    Date: Sat, 2 Jun 2007 10:26:16 -0400
    To: asd32@bellsouth.net
    From: admin@hft.com <admin@hft.com>
    Reply-to: admin@hft.com
    Subject: test
    Message-ID: <edb34e9b72812e7ddfbcd7a426d15cc6@www.hft.com>
    X-Priority: 3
    X-Mailer: PHPProBid/Sendmail [version 5.25]
    MIME-Version: 1.0
    Content-Transfer-Encoding: 7bit
    Content-Type: text/html; charset="iso-8859-1"
     
  2. psychodreams

    psychodreams Well-Known Member

    Joined:
    Apr 14, 2004
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    :)

    WHM-Server Configuration- Tweak Settings
    Check
    Prevent the user "nobody" from sending out mail to remote addresses (PHP and CGI scripts generally run as nobody if you are not using PHPSuexec and Suexec respectively.)
     
  3. Daveft

    Daveft Registered

    Joined:
    Jun 2, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi.
    But if I do this will I get any emails?
    All emails that I receive through the server from forms on my sites have nobody in the email header. The emails themself have the correct email address. It is just the small section of the email that has the word nobody in it.

    Most account don't like that and think it is spam.
    Return-path: <admin@hft.com>
    Envelope-to: admin@hft.com
    Delivery-date: Sat, 02 Jun 2007 10:26:16 -0400
    Received: from nobody by admin.mainhft.com with local (Exim 4.63)
    (envelope-from <admin@hft.com>)
    id 1HuUYa-0006Ln-2V; Sat, 02 Jun 2007 10:26:16 -0400
    Date: Sat, 2 Jun 2007 10:26:16 -0400
    To: asd32@bellsouth.net
    From: admin@hft.com <admin@hft.com>
    Reply-to: admin@hft.com
    Subject: test
    Message-ID: <edb34e9b72812e7ddfbcd7a426d15cc6@www.hft.com>
    X-Priority: 3
    X-Mailer: PHPProBid/Sendmail [version 5.25]
    MIME-Version: 1.0
    Content-Transfer-Encoding: 7bit
    Content-Type: text/html; charset="iso-8859-1"
     
  4. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    AFAIK, the only way to prevent that would be to

    1) use other scripts, or
    2) if they are php scripts, modify them so they are using the 5th -f param in the mail() functions, or
    3) switch to using suexec and phpsuexec*

    * If you're going to go that way, do your research first. It's a good and secure way to run a server, but there are a lot of ramifications.
     
  5. spearhead

    spearhead Member

    Joined:
    Mar 20, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    I'm find the best way is to have a php script that uses SMTP for sending (not the php mail() function). That works best.
     
Loading...

Share This Page