The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How do I install Subversion?

Discussion in 'General Discussion' started by xaze, Feb 28, 2009.

  1. xaze

    xaze Well-Known Member

    Joined:
    Jul 10, 2003
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    In WHM I go to Install a RPM and click on the subversion RPM. Then it fails and says:

    Code:
    Error: Missing Dependency: perl(URI) >= 1.17 is needed by package subversion
    
    However, when I go to Install a Perl Module and look for the URI module it says:

    Code:
    URI  	1.37
    
    1.37 > 1.17.

    So, how do I get this thing installed?
     
    #1 xaze, Feb 28, 2009
    Last edited: Feb 28, 2009
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    There are many threads on the forum about installing Subversion in cPanel/WHM environments. You may wish to perform a search. Note, Subversion is often abbreviated SVN.
     
  3. testlog_4u

    testlog_4u Active Member

    Joined:
    Sep 17, 2007
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    It is too late to respond but it will help other guys.. :)

    I had to remove 'perl*' from yum.conf and then 'yum install perl-URI'. Solved.


     
  4. damainman

    damainman Well-Known Member

    Joined:
    Nov 13, 2003
    Messages:
    515
    Likes Received:
    0
    Trophy Points:
    16
    testlog can I ask your flavor of linux? and thanks for providing your reply.
     
Loading...

Share This Page