how do I manually update the webstats?

SoftDux

Well-Known Member
May 27, 2006
1,024
5
168
Johannesburg, South Africa
cPanel Access Level
Root Administrator
For some odd reason, unknown to me, my server's web stats last ran on the 17th Novemember.

How do I manually run it?
And how do I see why it''s not running currently?

logged into WHM as root, and clicked on the "Statistics Software Configuration" and get this message:

The server is having trouble keeping up with your statistics processing schedule. You should increase the time between statistic generation, or upgrade the server. If you have recently decreased the time between statistic generation, you may wish to wait that amount of time to see if the server will catch up before changing back.
Show which users are behind
But why? My average server is load is below 2

Any suggestions?

tia :)
 

Un Area

Well-Known Member
Nov 16, 2006
90
1
156
Log in as root a run /scripts/runlogsnow

Then tell us if it gave you any error and if the stats were updated.

Bye!
 

SoftDux

Well-Known Member
May 27, 2006
1,024
5
168
Johannesburg, South Africa
cPanel Access Level
Root Administrator
Resetting Logs for cwayyorg...Done
Resetting Logs for joupaco...Done
Resetting Logs for frdplace...Done
/usr/bin/perl: error while loading shared libraries: /usr/local/cpanel/3rdparty/ lib/perl/auto/RRDs/RRDs.so: undefined symbol: Perl_Gthr_key_ptr
/usr/bin/perl: error while loading shared libraries: /usr/local/cpanel/3rdparty/ lib/perl/auto/RRDs/RRDs.so: undefined symbol: Perl_Gthr_key_ptr



That was right @ the end of the list, and none of the stats actually updated.

So, how do I fix those errors?
 

Un Area

Well-Known Member
Nov 16, 2006
90
1
156
btw, what version of perl are you using? try running perl -v
you should have version 5.8.7 if you have a lower version like 5.6.x, update perl.

Bye!
 

SoftDux

Well-Known Member
May 27, 2006
1,024
5
168
Johannesburg, South Africa
cPanel Access Level
Root Administrator
Thanx,

That seems to have worked. Only problem is, I now have to run the following script "/scripts/runweblogs" to update each user's logs.

/scripts/runlogsnow
didn't do it, probably cause it's set to run every 24 hours. So, without "disturbing" the server too much, I'll check and see tomorrow if all worked well, like it's supposed to :)

..... will keep you posted.