The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How do I null route e-mail?

Discussion in 'E-mail Discussions' started by GTFO, Dec 14, 2005.

  1. GTFO

    GTFO Active Member

    Joined:
    Aug 8, 2005
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    I have a user whose domain receives an ungodly amount of spam (one word domain name), and has opted to not use his mail at all because of it. This is great because he receives so much spam that it causes load spikes on the server.

    I removed his MX record from DNS thinking that this would stop mail from coming to the server, but it seems that even after about a week, the messages were either still cached OR, they were just tracing to the IP of the server and flatout sending it too that IP (I know that sounds far fetched, but somehow they are still getting to the server).

    My question, how do I prevent any and all mail for this domain from even hiting my server? I'd much rather not worry about his e-mail. Any suggestions?
     
  2. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    set the account to :fail:
     
  3. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    True, set the account's default address to :fail: and Exim will reject all mail for all invalid local recipients.

    Mail for valid local mailboxes and forwarders will still be received, so if this user really doesn't want any mail on this domain, it would be worth checking that all mailboxes and forwarders are deleted.

    Regarding the MX issue, some MTAs will route mail to the IP of a domain's A record either if an MX for the domain doesn't exist or just because they feel like it.
     
  4. GTFO

    GTFO Active Member

    Joined:
    Aug 8, 2005
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    I've already got the account set to :fail: , you've got to understand, I don't want our mail server to even acknowledge that a mail server exists for this domain. Nothing. This account receives so much of it, if we could stop it at DNS, that would be ideal.
     
  5. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    667
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    :blackhole: deletes is without anyone knowing to /dev/null im pretty sure.
     
  6. GTFO

    GTFO Active Member

    Joined:
    Aug 8, 2005
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Emphasis is on alleviating load. Blackhole will still write to the exim_mainlog and actually consumes more resources than :fail: (for a reason that escapes my memory at the moment). I flat out don't want mail to hit my mail server from this domain at all.

    An idea was suggested, creating an A record to point to 0.0.0.0 for mail.domain.com and then setting up the mx record for that domain to refer to mail.domain.com . Has anyone every tried this?
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You cannot avoid email actually hitting the server if you have the A record of the TLD pointing to it. This is because the SMTP protocol allows the use of the A record if the MX record doesn't resolve. You could try pointing the A record for the subdomain used by the MX record to outer space, but you may still get some email hitting the server. For that, simply take the domain name out of /etc/localdomains and stick it in /etc/remotedomains (create if needed). That's the best you can do.
     
  8. GTFO

    GTFO Active Member

    Joined:
    Aug 8, 2005
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6

    Thats a good idea.. i'll give that a try and post m' results after about a week. Thanks
     
Loading...

Share This Page